# Collabora admin login required after server restart

**URL:** <https://forum.collaboraonline.com/t/collabora-admin-login-required-after-server-restart/2230>\
**Category:** Installation & Configuration\
**Created:** [December 6, 2023, 7:03am UTC](https://forum.collaboraonline.com/t/collabora-admin-login-required-after-server-restart/2230 "2023-12-06T07:03:52Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Lulina](https://avatars.discourse-cdn.com/v4/letter/l/ce73a5/32.png) [@Lulina](https://forum.collaboraonline.com/u/Lulina)\
**Post date:** [December 6, 2023, 7:03am UTC](https://forum.collaboraonline.com/t/collabora-admin-login-required-after-server-restart/2230/1 "2023-12-06T07:03:52Z")

</div>

Good day everyone!

I created a Collabora server which our NC servers use with NC Office

After a server restart of Collabora, NC Office can still successfully detect the Collabora server but opening documents lead to an error

When I login in to browser/dist/admin/admin.html, the issue is resolved

What causes this little quirk and whether there’s a possible workaround

Additional info:  
Collabora 23.05.5.4  
NextCloud 27

Any insight would be appreciated 🙂

---

<div class="post-metadata">

**Author:** ![Tex](https://avatars.discourse-cdn.com/v4/letter/t/eb8c5e/32.png) [@Tex](https://forum.collaboraonline.com/u/Tex)\
**Post date:** [December 7, 2023, 12:18am UTC](https://forum.collaboraonline.com/t/collabora-admin-login-required-after-server-restart/2230/2 "2023-12-07T00:18:33Z")

</div>

Hey @Lulina. Welcome to the forum + thanks for the post!

I’m going to move this to the “Installation & Configuration” section of the forums, where others might be able to find/help you better. 🙂

> [@Lulina](#):
>
> I created a Collabora server which our NC servers use with NC Office
> 
> After a server restart of Collabora, NC Office can still successfully detect the Collabora server […]

Okay, I’m a little confused.

Let me see if I’m understanding correctly:

- You are running Nextcloud.
- You installed Collabora Office (or Nextcloud Office?).
  - Which one?

- You can get to `/browser/dist/admin/admin.html` successfully, but can’t open documents.

**QUESTION #1:** Did you follow any installation instructions? Can you link them here?

* * *

There is also a helpful topic over at the Nextcloud forums which might have some Nextcloud\<-\>Collabora troubleshooting tips too:

- [Nextcloud Forums: “Collabora integration”](https://help.nextcloud.com/t/collabora-integration/151879)

Perhaps one of their debugging steps might help you.

* * *

> [@Lulina](#):
>
> […] but opening documents lead to an error

**QUESTION #2:** Can you tell which exact error appeared?

---

<div class="post-metadata">

**Author:** ![Lulina](https://avatars.discourse-cdn.com/v4/letter/l/ce73a5/32.png) [@Lulina](https://forum.collaboraonline.com/u/Lulina)\
**Post date:** [December 7, 2023, 8:32am UTC](https://forum.collaboraonline.com/t/collabora-admin-login-required-after-server-restart/2230/3 "2023-12-07T08:32:27Z")

</div>

Hi there Tex

Thank you for you time 🙂

> ```
> You are running Nextcloud.
> You installed Collabora Office (or Nextcloud Office?).
> Which one?
> 
> ```

We have several self hosted NextCloud servers  
On those servers the app, Nextcloud Office 8.2.3, is installed and configured to connect to the Collabora server ie [https://domain.com:9980/](https://domain.com:9980/)

> ```
> You can get to /browser/dist/admin/admin.html successfully, but can’t open documents.
> 
> ```

Before I access /browser/dist/admin/admin.html, documents won’t open. **After** I login with the admin credentials, the documents open and can be edited again.

> **QUESTION #1:** Did you follow any installation instructions? Can you link them here?

[Here you go](https://www.collaboraoffice.com/code/linux-packages/), this was installed on Ubuntu 22.04

> **QUESTION #2:** Can you tell which exact error appeared?

Unfortunately I did not document the errors, total oversight on my part. They were along the lines of “Failed to load document” and “reverse proxy”

Thank you for the troubleshooting link, I will have a read through

Hope to hear from you soon 🙂
