# Some errors with docker image

**URL:** https://forum.collaboraonline.com/t/some-errors-with-docker-image/1970
**Category:** Installation & Configuration
**Created:** [July 29, 2023, 9:01pm UTC](https://forum.collaboraonline.com/t/some-errors-with-docker-image/1970 "2023-07-29T21:01:33Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![rimkov](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.collaboraonline.com/rimkov/32/829_2.png) [@rimkov](https://forum.collaboraonline.com/u/rimkov)
#### Post date: [July 29, 2023, 9:01pm UTC](https://forum.collaboraonline.com/t/some-errors-with-docker-image/1970/1 "2023-07-29T21:01:33Z")

</div>

hi  
i have a CODE (23.05 official image) instance deployed on Kubernetes cluster and i’m using it with Moodle plugin. Everything seems ok but i have some errors on logs :

```auto
wsd-00001-00098 2023-07-29 22:38:14.794552 +0200 [docbroker_005] ERR Invalid or missing JSON in WOPI::PutFile HTTP_OK response.| wsd/Storage.cpp:1484
wsd-00001-00098 2023-07-29 22:41:58.827799 +0200 [docbroker_005] ERR #26: Read failed, have 0 buffered bytes (ECONNRESET: Connection reset by peer)| net/Socket.hpp:1122 

```

how can i correct them ?

I also have this message,

```auto
WRN The systemplate directory [/opt/cool/systemplate] is read-only, and at least [/opt/cool/systemplate//etc/hosts] is out-of-date. Will have to copy sysTemplate to jails. To restore optimal performance, make sure the files in [/opt/cool/systemplate/etc] are up-to-date.| common/JailUtil.cpp:524 

```

but I can’t execute the command `coolconfig update-system-template`  
as root

thank you for your help 🙂

we are very glad to see more accessibility with 23.05.

---

<div class="post-metadata">

### Author: ![Tex](https://avatars.discourse-cdn.com/v4/letter/t/eb8c5e/32.png) [@Tex](https://forum.collaboraonline.com/u/Tex)
#### Post date: [August 3, 2023, 7:28am UTC](https://forum.collaboraonline.com/t/some-errors-with-docker-image/1970/2 "2023-08-03T07:28:13Z")

</div>

Hey @rimkov,

Thanks for the question.

Can you give a little more info, like:

- What OS are you on?
- Which exact version/s you are running?
  - In Collabora Online, in **Help \> About** , a little copy button exists too.

* * *

> Everything seems ok but i have some errors on logs :

Hmmm, I did a little search for:

- `WOPI::PutFile`
- `ECONNRESET: Connection reset by peer`
- + Collabora

and it seems like most of those are errors where people are failing to load/open/create their documents.

You said it’s working fine though… so… maybe everything’s okay? 😛

The closest I could find was this issue:

- [Cannot save at all · Issue #34 · CollaboraOnline/collabora-mattermost · GitHub](https://github.com/CollaboraOnline/collabora-mattermost/issues/34)

where there was lots of discussion and a user also had your line:

- `Invalid or missing JSON in WOPI::PutFile HTTP_OK response.`

Maybe there’s some other useful info in there.

* * *

On your warning:

> WRN The systemplate directory [/opt/cool/systemplate] is read-only, and at least [/opt/cool/systemplate//etc/hosts] is out-of-date. […]

Do the instructions here help?

- [sdk.collaboraonline.com: “Updating systemplate”](https://sdk.collaboraonline.com/docs/installation/Updating__systemplate.html)

---

<div class="post-metadata">

### Author: ![rimkov](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.collaboraonline.com/rimkov/32/829_2.png) [@rimkov](https://forum.collaboraonline.com/u/rimkov)
#### Post date: [August 5, 2023, 7:18pm UTC](https://forum.collaboraonline.com/t/some-errors-with-docker-image/1970/3 "2023-08-05T19:18:11Z")

</div>

hi!

thank you, i’m using the official docker image 23.05.2.2.1  
indeed everything works so if I can ignore them I will 😉

> Do the instructions here help?

i found these instructions, but i cannot execute this command because i’m not root due to the official docker image.

---

<div class="post-metadata">

### Author: ![rimkov](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.collaboraonline.com/rimkov/32/829_2.png) [@rimkov](https://forum.collaboraonline.com/u/rimkov)
#### Post date: [August 10, 2023, 3:16pm UTC](https://forum.collaboraonline.com/t/some-errors-with-docker-image/1970/4 "2023-08-10T15:16:17Z")

</div>

systemplate directory is owned by root

---

<div class="post-metadata">

### Author: ![rimkov](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.collaboraonline.com/rimkov/32/829_2.png) [@rimkov](https://forum.collaboraonline.com/u/rimkov)
#### Post date: [August 22, 2023, 7:49am UTC](https://forum.collaboraonline.com/t/some-errors-with-docker-image/1970/5 "2023-08-22T07:49:28Z")

</div>

i tried to make a custom image from packages and removed USER 100 from the original Dockerfile but now i cannot run cool :

```auto
Failed to initialize COOLWSD: Do not run as root. Please run as cool user.
-00001 2023-08-22 07:41:34.630244 +0000 [coolwsd] FTL Failed to initialize COOLWSD: Do not run as root. Please run as cool user.| wsd/COOLWSD.hpp:514
Do not run as root. Please run as cool user.

```

so how can we update systemplate ? thank you
