Nextcloud 21.0.7 & CODE gives a white/blank page on opening Office documents


our issue is similar to some already mentioned, but still different: I have install the Collabora Online app in Nextcloud (21.0.7) and the CODE server on the same VM (running CentOS 7.9). CODE has been installed via yum/rpm and is running on port 9980 without(!) proxy, as it is running on the same host as Nextcloud. SSL has been disabled in coolwsd.xml. The local firewall has - for the time being - been completely stopped.

When opening an Office document, I get a white/blank page with just the Nextcloud menu. There are no errors or other messages in the system log, /var/log/coolwsd/coolwsd.log (level set to “warning”) or in the Nextcloud log.

In the Nextcloud settings I can configure the Collabora Online server as http://IP_OF_VM:9980 and get a green “OK” bullet. However if I try to configure it as or http://localhost:9980 I get a red connection error warning bullet.

I had the same issue also with the Docker setup and with Nexctcloud’ build-in CODE server setup.

I’m at a complete loss here and I am grateful for any pointer towards a solution or ways to debug this.


That’s strange, I’d expect CODE service to be listening on any IP/host name referring to the current host, if you curl each of those locations, do they each result in “OK”? In addition, http://<ip/host>:9980/hosting/discovery should return an XML in each case.

Docker containers are an exception, you can’t use any “localhost” reference, because the WOPI request won’t find its way back from within the container, but that will only be a problem once you try opening a file I think.

You didn’t mention, but Nextcloud is on http as well, right?

http://localhost:9980/ and curl http://IP_OF_HOST:9980/ return “OK” and curling /hosting/discovery returns XML.

curl returns


Nextcloud is on https, but since Collabora is running on the same VM I have disabled SSL in /etc/coolwsd/coolwsd.xml

Nextcloud and COOL need to both agree on http or https - then again to make certificate setup easier - quite probably it is best to use Apache as a proxy in front of COOL: you can checkout setting up an Apache or NGINX reverse proxy here:

Hope that helps.

Thanks to all hinters :slight_smile:

We implemented the reverse proxy with SSL termination as described on Proxy settings — SDK documentation and everything works fine since then

:candle: Merry christmas and a happy new year to everybody :candle: