Only the download dialog appears when I want to open a document


I have an problem, with one of my nextcloud instances after I restored the installation from a backup (only data and db dump was available). Now, I can’t open any document file wit collabora. Only the download dialog and no error message appears. I can’t find anything in the admin page error log either. If I want to create a new file, a dialog opens and ask me for a template. If I choose one, the error message Unable to create new file from template appears.

I use Nextcloud 23.0.0 and Collabora 5.0.0. The collabora docker container is fine, because I use it for a second Nextcloud 22 instance too.

I already tried to reinstall the collabora online app, run the command php occ maintenance:mimetype:update-db --repair-filecache and created a mimetypemapping.json file:

    "odt": [
    "ods": [

Thanks for answers,

Does the Office settings in Nextcloud show a green checkmark? Do you have a reverse proxy set up for the container? If you don’ t have one, do you have the Disable certificate verification (insecure) setting checked? (because the container uses a locally generated certificate by default)

There is the green checkmark and I tried it with Disable certificate verification (insecure) without success.

There is an optional reverse proxy. There is the following situation. There are two server in my flat. The first is the main server, which listen on port 80 and 443. The second, where this Nextcloud instance is running, listen on port 9300. Therefore there are two possible domains, to access the nextcloud. There is a domain, which points direct to the port 9300 of the Nextcloud server (second) and there is a port 80/443 sub domain, which points the main server and redirect to the port 9300 sub domain. I uses the direct domain to avoid problems with the reverse proxy.

The main server create all certificates via letsencrypt and send the required certificates to the second server. On the main server there is a collobara container running, which is used by nextcloud instances of the second server and also by a nextcloud instance running on the main server. Before I restored the backup, it worked well and collabora is still working on the instance on the main server.

I think the way richdocuments was checking the proxy status might have been the culprit but it seems to have been fixed Properly check proxy status by juliushaertl · Pull Request #1900 · nextcloud/richdocuments · GitHub

@bearon , do you think this would be somehow related to the renaming of some strings within the configuration setup? Proxy settings — SDK documentation

other related issues: v5.0.0 don't work with Collabora · Issue #1895 · nextcloud/richdocuments · GitHub