Unauthorized wopi host Docker-Compose Nextcloud


If I try to open an document in my nextcloud I will get the error my wopi host is unauthorized.

First of all: my system was running fine, until I changed my Internetconnection (cable to fibre, same ISP)
But I got a new firewall and IP-Adress.

I know, I have to change the “Allowed Wopi-Host” in my nextcloud under Settings / Office / Allow list for WOPI requests. So I changed the IP-Adress to my actual (like it was before). But the error remains.
If I clear the List. The Document will open. (!)

Now I go to https://collabora.mydomain.de/browser/dist/admin/admin.html I could see my user with the wopi-address “cloud.mydomain.de”. But even if I go to settings and take this as WOPI-Host it would`nt run. does also not work.

Thank you all!

Hey @Monokel777. Welcome to the forum + thanks for the question. :slight_smile:

Hmmm… those bold parts seem like it could be important.

What do you mean by “got a new firewall”?

And can you give a little more info on your setup? What is the versions of:

  • Collabora
  • Nextcloud
  • richdocuments
  • OS

Hmmm… And did you try going through the helpful “checklist” over at the:

Are other things working in your Nextcloud, and only Collabora is the one not connecting properly?

(It’s probably just an old single line buried in some setting file somewhere… It always is! :smiley: )

Thanks for your Response!

So, Step by Step.
My New Firewall is an “Ubiquiti UniFi Dream Machine Pro”. Here I have activated Protforwarding (443, 80) to my Raspberry Pi (4 - 8GB) running Docker.

My Versions:

  • Collabora:
  • Nextcloud: Hub 7 / 28.0.2
  • Nextcloud: Office: 8.3.1
  • OS: Debian GNU/Linux 11 (bullseye)

Thank you for the Checklist. I think my whole system is great except the WOPI client.

Yeah, the Cloud runs as usual and if i empty the WOPI-Allow-list the Cloud runs also. I think I did’nt change any line of code in any config-file or outside an GUI.

My “Solution” was to insert my “Server-VLAN” gateway address.
Now it works. I found that by looking in the logs direktly from nextcloud (not office) there the WOPI-address was my (“internal”)Gateway. feels not good, like everyone could get to my office-server trough my gateway, but I hope its okay.

1 Like