Can not create doc, docx and odt

Hello community,
first of all i would like to thank you a lot for Collabora as a product/service we really like to use it here.

Now we have updated our environment it to Nextcloud 23.0.3 and COOLWSD to with Collabora OfficeDev on Debian Bullseye.

Im not able to create new doc, doc or odt files anymore. It looks like this:

Is this a bug caused by Nextcloud or Collabora?

Found the issue. I had to switch back to “notebookbar” in the coolwsd.xml, afterwards the documents got opened again as they should and everything is working again normal.

For me it works fine even when <user_interface> / <mode> is set to default or classic.
It might be worth checking if you see any errors in the browser console if you switch the setting back.

Problem still persists, but only with Firefox. Chromium is fine. For me it also seems that it is only happening with .doc, docx, and .odt files, or so to say with Writer. Calc and Impress seem to be fine.

Here are some screenshots from the console, hope it helps.

Hope that helps. Sorry for posting again and again, but im only allowed to upload one pic at a time.

I am using a Reverse Proxy (NGINX), separate machine for CODE and Nextcloud 23 with Apache, everything running on Debian Bullseye.

@bearon I could share a link with you to an example file if you would like to debug it with me.

Believe it or not, this “hanging up” does not happen with a public link generated by Nextcloud itself. It only happens when im actually logged in. I have no clue…

Any chance of an account on your box for testing ? if so mail - thanks ! I’d say use a shared-link, but seemingly that works. Very odd that it is FF specific.

The hideWizard error is here:

    _hideWizard: function () {
      if (app.sectionContainer) {

at this point is “comment list” and app.sectionContainer is non-null, but its members sectionContainers.sections is an empty list, sectionsDirty is false and windowSectionList is also []

So looks like rather an under-initialized CanvasSectionsContainer. So - I guess some early start race (?). Stack trace is:

_hideWizard (
   EventListener.handleEvent - presumably setup here:
onAdd (
addControl (
initializeBasicUI (
<anonymous> (
<anonymous> (
<anonymous> (

So ultimately from onAdd’s handler getting called for:

  window.addEventListener('resize', this._hideWizard.bind(this));

Frustratingly Firefox appears not to have an easy way to override server-delivered JS - so (no doubt) there is another bug underneath this one that may cause some grief but: Don't try to hide comment section if mobile wizard not enabled. by mmeeks · Pull Request #4712 · CollaboraOnline/online · GitHub may help as/when it gets in.
Gokay also has this one which is not merged yet which may help: Private/gokay/ff improvements by gokaysatir · Pull Request #4711 · CollaboraOnline/online · GitHub

Thanks for your engagement!
I will try as soon as it lands!

I don´t want to shout it out too early, but it seems that the problem is fixed.
The update to Nextcloud Office 5.0.5 seemed to made the difference.

However… i have opened a few dozen documents without any trouble in Firefox. It is still laggy, but it opens without issues.

Even scrolling is working, but CPU is high and it´s far not as good as it is with Chromium.