Cannot access any file even when --o:storage.filesystem[@allow]=true

Hi everyone,
I’m working on my own Collabora/code integration, but I do have a minor issue with file sharing when it’s deployed. So I tried to localize the issue and found out that even the simplest file sharing doesn’t work.

What I do is run docker image using the command:

docker run --rm -it -p 9980:9980 -e "extra_params=--o:ssl.enable=false --o:storage.filesystem[@allow]=true" collabora/code

Then open a browser and go to:


, from there I get WOPI address.

The last step is to open any file from the filesystem, which should work. In Collabora documentation, they explicitly say that you shouldn’t do this (security reasons). So I go to page:


But get the error about permissions.

Can anyone help me please find out what’s wrong with this solution?
Or tell me if I’m missing any additional steps that need to be done.


When accessing files locally, the URL parameter is file_path=<file_with_path>, where <file_with_path> is eg. file:///home/user/something.odt
(and yes, it’s only advised for testing purposes)

The regular way requires a host that can adhere to the WOPI protocol on the other end.