Collabora not working with nginx proxy

I have pulled the collabora image from docker and using django for wopi. I have configured reverse proxy in nginx as mentioned in collabora docs. I am not able to open documents from collabora and hit is not going in django.

Please find below response of url (/hosting/capabilities) from browser

The /hosting/capabilities response looks fine.
Would be good if you could set log level to trace, try opening a document using your WOPI setup, then check the logs in the container if you see requests coming from the WOPI host, and what happens afterwards.

When I open a document by hitting url, no logs are coming in django.

Not django, the logs of the CODE container.

In that case, I cannot change as I have pulled the image directly. I tried to apply logs inside the container but it needs root permission. So I think I need to download it from source. Please let me know if I am wrong.

You can get the logs via: docker logs <container id>

No I am getting any logs when I am hitting wopi url in collabora container logs.


I can see that collabora is fine, but it is not opening the wopi url. When I hit collabora with WOPISrc it is giving not found. Also I checked django and collabora container logs.
No information is coming in collabora container logs
No request is coming in django logs and connection reset by peer is coming again and again.

@shii does it work now ? do you need any help ? If it still doesnot work can you share the docker logs
using docker logs <container_name> ? I tried setting up CODE + nextcloud + nginx reverse proxy and everything works for me : )