Net conf issue about collabora online service

Docker bootup successfully, and be able to access from localhost. Here is what I am:

[root@ecs-274467 ~]# curl -k https://localhost:9980

But I am not able access from public IP, there is no response by below command.

curl -k

with below errors in logs:

wsd-00001-00001 2022-03-23 02:47:56.781787 +0000 [ coolwsd ] INF WSD initialization complete: setting log-level to [warning] as configured.| wsd/COOLWSD.cpp:4319
Ready to accept connections on port 9980.

wsd-00001-00040 2022-03-23 03:18:35.800919 +0000 [ websrv_poll ] ERR #23 Error while handling poll at 0 in websrv_poll: #23 SSL BIO error: error:1408F09C:SSL routines:ssl3_get_record:http request| net/Socket.cpp:466

What I have tested:

  1. setup a nginx and access from internet sucessfully,so the ECS environment should be fine,
  2. collabora online service can be ok with local access
    So, suppose the issue could be inside the net conf of collabora service.

Any advises will be appreciated.
btw, No SSL needed in case this issue related to SSL, so if the easiest way is disable SSL, that make sense to me. but how to make it in conf ? …

Welcome to the forum @Robby , which docker image version are you using?

Also the allowed hosts can be set within coolwsd.xml more info on: Configuration — SDK documentation

Hi,Petdro,I was using this command to pull image from official site:

docker pull collabora/code

I just got workaround to make it by referring " Quick tryout with Nextcloud docker" . So far so good. Thanks anyway.

1 Like

DNS resolve error since last update · Issue #4480 · CollaboraOnline/online · GitHub this issue has been fixed on latest docker image :slight_smile: