Partially working? 0% connected

Hi all,

Trying to deploy a Collabora CODE installation, to integrate with OwnCloud. Owncloud works flawlessly, and I can see the endpoint and admin areas perectly at:

https://collabora.domain.io/hosting/discovery
https://192.168.1.7:9980/hosting/discovery
https://collabora.domain.io/loleaflet/dist/admin/admin.html
https://192.168.1.7:9980/loleaflet/dist/admin/admin.html

When attempting to open/create a document in OwnCloud Collabora hangs at this stage:

I’m at a loss as to how I can progress at this stage, having tried with both a native CODE install to a dedicated fresh Debian 10 VM, as well as the Collabora docker container. The result is the same with either context, so I’m clearly missing something.

I have a feeling it is likely reverse proxy related, having looked at the Apache and Nginx setups in the documents, but I can’t see why it would be a problem, if I can successfully navigate to any links otherwise.

Are there other endpoints I can test?

My infrastructure is:

[CF]
* Using CF as a proxy in front of my hosted services (can do DNS only, if required)

[OPNsense]
* All traffic funneled through port 443 only, connections only accepted from Cloudflare IPs

[VM1]
Docker:
* traefik (reverse proxy)
* OwnCloud
* Collabora SSL (termination @ traefik)

[VM2]
* Collabora dedicated VM, native CODE install
* SSL enabled, Origin Certs installed. Working just fine.

Any tips would be greatly appreciated.

On your collabora docker, use tag 6.4.9.3
6.4.10.* are broken when any kind of SNI is involved (probably this is the cause but not sure.
There is a commit that fixes the SNI a couple days ago, but the image are not uploaded yet on dockerhub.

1 Like

Hi Tom,

we had the same error with the nextcloud app after upgrading to 6.4.10 (subversion 1003)
On Saturday I’ve installed subversion 1004.
The error did not show up again since then.

P.S.: What is SNI?

1 Like

Thanks, I’ll try this!

Server Name Indicator. The way Cloudflare wrote about it made the most sense to me: https://www.cloudflare.com/en-gb/learning/ssl/what-is-sni/

Good news! Will try it out.

6.4.9.3 worked perfectly with no other changes to my setup, thanks!

Experiencing the same issue with [6.4.10.5], but not with [6.4.10.4]

Just pulled [6.4.10.6] and everything seems to be working fine…

2 Likes

I’m not using docker. can you duide me how to use old image?
this is how I install it on my vps
echo ‘deb Index of /repos/CollaboraOnline/CODE-ubuntu2004 ./’ | sudo tee /etc/apt/sources.list.d/collabora.list