Resolve error "because it violates the following Content Security Policy directive: "connect-src 'self'"

I have collabora community edition.
i am calling another domain webservice from cool.html javascript. collabora gives error "because it violates the following Content Security Policy directive: “connect-src ‘self’”. there is one settings in coolwsd.xml “content_security_policy”.
need urgent help to resolve this issue.

Can you give some idea of the context you’re working in and details on the urgency constraint here? Its a little hard to understand your problem without more details and work. Please don’t add this request to several forum posts to try to speed things up.

in cool.html i am trying to call webservice outside of the collabora server. its an ajax call call to outside domain. from collabora viewer we get the error “Refused to connect to ‘https://outsidecollaboradomain/web/service/path’ because it violates the following Content Security Policy directive: “connect-src ‘self’ wss://”.”. I have tried to change the content_security_policy in coolwsd.xml. and i am suing nginx server. in nginx server also i added header but the same result. need urgent help to resolve this issue.

It’s currently Christmas & the New Year, break; nevertheless Collabora keeps a live support team working across the break to solve urgent problems for partners and paying customers. If you need this level of support you should seriously consider either becoming a partner or getting a support contract, and then filing tickets in our support portal. If you can provide more details on your use-case / commercial requirements of course - what integration, deployment etc. perhaps we can help you but - I would really suggest supporting the project by contributing to development via paid support.

1 Like

the use case is we need to register when the actual viewer opened successfully. We are very small group of 20 people. and we need to explore all options from collabora before we implement in our inner group environment. That’s why the urgency is there. if you can help it will be great help.

Thanks a lot. i have figured how to overcome the issue. it can be done by CSP setting in collabora.

Hey @shakti, Great to hear you fixed it. :slight_smile:

Can you please explain what setting you changed? And/or where you found the info/solution?

That would help anyone else who ran across a similar problem in the future!

You may also want to visit the:

and “Request a Quote”.

Like @mmeeks said, if you:

  • Needed more dedicated/faster support
  • Have many (20+) users

then it’s offered for a reasonable fee per user / per year.

These forums are more for helping solve questions/problems at their own pace… and many people answering could just be normal Collabora users / volunteers. :slight_smile: