Status report: consultancy team, week 49, 2023


  • master online works now works to serve wasm with experiment to allow chrome to work, success
  • but can’t always type, which is a nuisance
  • notebookbar doesn’t work either
  • check to see if my split calc panes error was in release branch
    → nope
  • update crashtesting
  • git ci is fails a lot for me in UnitBadDocLoad
    duplicate jsdialog messages seen in UnitBadDocLoad by caolanm · Pull Request #7777 · CollaboraOnline/online · GitHub
  • add thoughts on keyboard accessibility question for link activation
  • ofz#64582 Out-of-memory in new apng stuff
  • fix a regression of tdf#158441 we don’t want to return early for
    all handled keys
  • fix some other regression with help in print dialog
  • check optimized wasm build without debuginfo from scratch
  • will fail to create .debug so missing file then
    use of gseparate-dwarf can block some optimizations by caolanm · Pull Request #7728 · CollaboraOnline/online · GitHub
  • figure out a way via capabilities and nextcloud php stuff
    to conditionalize wasm headers so we don’t have to have those always
    on which is causing breakage on integrations with content pulled
    from different sites
  • it works → add hasWASMSupport to capabilities by caolanm · Pull Request #7784 · CollaboraOnline/online · GitHub
  • which unblocks upstream merging his patch for all of this
    for nextcloud 28
  • debug cypress test to see why writer/shape_properties_spec fails
    for me
    → different start position after resize of browser window
  • debug wasm+browser to try and see if the keystrokes hit
    javascript and go on to wasm or where they disappear
  • try debugging common wasm app failures
  • look at why notebookbar doesn’t load
  • tile weirdness
  • missing start of logs, which would be helpful to have
    enable window.logging before dumping delayed log by caolanm · Pull Request #7791 · CollaboraOnline/online · GitHub
  • debug hang seen during COOL call a bit, turn into an
    dbgutil assert and run-time failure to save instead of a hang
  • debug broken notebookbar on wasm
    → enable-qt is the default for the wasm distro config, but that
    breaks the custom widget case, and so notebookbar contents are
    not found, so --enable-qt is a poor choice, add a new lokit+wasm
    distro target
  • debug missing keystrokes on wasm
    → wasm case is derived from the mobile case and it thinks there
    should be an on-screen keyboard, which there isn’t, submit another
    fix for that.
  • SfxDispatcher::SetMenu_Impl is 3.1% of long-term profile
  • merge ash’s wasm stuff
  • request and publish the github cves for richdocumentscode
  • patch review of a few viewid gotchas
    • work on putting together a proper test for the flipping
      dark mode on while there are still tiles queued from
      an earlier request getting processed


  • After saving signed document, signing is removed, but macros remain signed
    • backported to distro/mimo/mimo-7-5 and distro/mimo/mimo-7-3
  • Document disappears from view with certain actions
    • Repro; but the difference is on Online side
    • We likely just need to do the same in Online, as done in core: do not
      follow the cursor outside of page bounds
    • Does Online know what the current page bounds are? If it does, it
      simply needs to check the coordinate in a method used to re-position …
      needs debugging
    • What sends clientvisiblearea? The call stack from that point should
      give some pointers…


Upstream bugfix tdf#123396

  • provide a fix and backport cp-23.05

SVG OOXML support

  • resurrected mostly done with the patches
    • fixed the issues and written the tests
    • backported to co-23.05

Textbox font size change in edit mode

  • research the issue a bit, estimated
    • something influences the scale a bit
    • not stable
    • difference in rendering path when in edit mode over viewing only
      (drawing layer)

video playback on iOS, macOS when full-screen presentation

  • setting up the environment for iOS and macOS
    • connecting over (local) wireless network to a COOL instance very
      slow - refuses to properly connect
    • over time and many tries did manage to do it however - weird
    • on macOS no problem with Chrome, but Safari doesn’t work
    • and iOS Safari
  • tried to reproduce this, but video playback doesn’t work at all for me
    using Safari
  • could be an issue with the connection
  • could be due to rather old macOS version also
  • no problem with Chrome… again
  • the placeholder box does appear so I will assume this is the correct
    place where the video would appear
  • got the Skyler’s WIP patch
    • doesn’t place the box correctly for me neither in macOS nor iOS
    • just moving using the offsets doesn’t seem to do the trick
      • the video box appears at different position in macOS and iOS
        (depending on the orientation)
    • probably depends on the viewport size - need to find something that
      gives me stable results
    • size seems to be correct however