Upgrade from loolwsd to coolwsd broke Nextcloud use

Hello, I did apt updates that switched from loolwsd to coolwsd. I’ve completed /etc/coolwsd/coolwsd.xml with the correct settings, the service is up and listening on port 9980, but when loading a file from Nextcloud, nothing happens anymore (or more precisely it seems it is loading Nextcloud in Nextcloud (sic) instead of displaying the document - I have two Nextcloud topbars…).
Did anyone run into similar problem? How could I solve it?

1 Like


I’ve got the same problem with a 404 error code.

Thanks for any help

Count me in as well. I’m running nginx with nextcloud (22.2.3) and my own collabora server. I’m not able to find any errors in my logs. I’ve looked through all the usual places only to find none appear to by involved. I changed the loolwsd entries in collabora.config to coolwsd. The server is running and Nextcloud displays all non-office documents (.jpg. .png .pdf .txt, etc) correctly but any LibreOffice files result in 404 not found. A search of the internet netted nothing of value. If I switch to a demo collabora server all is shiny.

I’m grateful for any guidance,

you must change the nginx config. Where you had ‘lool’, you must write ‘cool’, and where you have ‘loleaflet’ you must write ‘browser’.
The correct URLs are visible in /hosting/discovery.

1 Like

THANK YOU SO VERY MUCH joergmschulz.
That works FANTASTICALLY well. One minor difference. The changes you listed are in collabora.config not nginx. I had already made the changes regarding “lool” to “cool” but not the “loleaflet” to “browser”. All is shiny once again.
Again, thank you so much.

Thank you very much :pray:

Indeed, I didn’t even think to look at my Apache conf!

All is working now :sunglasses:


I still have a problem when I try to open a file. I still have a message notifying that the server has been disconnected. Can you give your settings in Apache or Nginx ?

Thank you for help.


Hi, here are mine:

AllowEncodedSlashes NoDecode

SSLProxyEngine On
SSLProxyVerify None
SSLProxyCheckPeerCN Off
SSLProxyCheckPeerName Off

ProxyPreserveHost On

ProxyPass           /browser retry=0
ProxyPassReverse    /browser
ProxyPass           /hosting/discovery retry=0
ProxyPassReverse    /hosting/discovery
ProxyPass           /hosting/capabilities retry=0
ProxyPassReverse    /hosting/capabilities
ProxyPassMatch      "/cool/(.*)/ws$" wss://$1/ws nocanon
ProxyPass           /cool/adminws wss://
ProxyPass           /cool
ProxyPassReverse    /cool

I don’t guarantee it’s the best way to do it but it works.

Hope it helps.

Thanks Ademma for your help. Unfortunely, it doesn’t work. I do use Nginx and I tried to adapt your solution, but I still get the same message “The server is disconnected”

What’s your log files look like? Any errors each time you attempt connection?
Is the server running? Is there a proxy involved?

This helped me solve the problem last night’s update created for me. Thank you so much.

How would I find out about such major changes in advance? Is there a newsletter or anything similar for sysadmins that would point out such changes as a new version is released?

1 Like

i’ve got exactely the same problem !
nextcloud lastversion, after upgrading collabora, and change leaflet->browser and lool->cool in nginx conf, it doesn’t work with NC, i ve got the message “server is disconnected”
nothing interessant in log
the coolwd service is running
somebody with nginx, nextcloud, and CODE has a working configuration ?
thanks for help

I fixed it this morning adding my nextcloud server domain name in the “hosts” file.

yeah !!!
it was the solution
parfait merci !
Laurent S

Hi to everyone!
I had the same problem after upgrade to NC 23.
I used the solution and now I can open files from logged in accounts in NC.
But I have a problem with shared folders. The folder is opens great but I cant open files in it.
There are “Document loading failed. Cannot load Nextcloud Office” message.
Any solution?