503 when loading documents from Nextcloud RichDocuments application [Solution]

I was recently dealing with an issue regarding Collabora that did not seem to have been addressed, hence I felt I should offer my solution for anyone facing the same issue.

Below are my system specifications:
Operating System: Ubuntu 21.10
Nextcloud Version: 23.0.12
Coolwsd Version:

Collabora was running fine, and Nextcloud was able to connect, however loading documents always failed. I managed to locate the following error in the log file (I run the daemon).

[ docbroker_021 ] ERR  WOPI::GetFile [https://nextcloud.example.com/index.php/apps/richdocuments/wopi/files/1154724_oc6bar4985a2/contents?access_token=&access_token_ttl=0&permission=edit] failed with Status Code: 403| wsd/Storage.cpp:1142
[ docbroker_021 ] ERR  Cannot download document from WOPI storage uri [https://nextcloud.example.com/index.php/apps/richdocuments/wopi/files/1154724_oc6bar4985a2/contents?access_token=&access_token_ttl=0&permission=edit]. Error: WOPI::GetFile [https://nextcloud.example.com/index.php/apps/richdocuments/wopi/files/1154724_oc6bar4985a2/contents?access_token=&access_token_ttl=0&permission=edit] failed: []| wsd/Storage.cpp:1073

From a cursory glance, the issue appears to be that no access_token value is being provided in the URL request. I spent weeks tweaking the Apache Reverse Proxy configuration, along with the coolwsd.xml file, to no avail.

Eventually, I stumbled across a comment from a Reddit post here, which suggested the issue was related to the version of the richdocuments application running on Nextcloud.

Following the suggestion, I downgraded richdocuments to the first release version for Nextcloud 23.xx (the download directory can be found here).

<cd to Nextcloud apps directory>
wget https://github.com/nextcloud-releases/richdocuments/releases/download/<version>/richdocuments-<version>.tar.gz -O richdocuments_<version>.tar.gz
tar -xvf richdocuments_<version>.tar.gz
(If running Nextcloud outside Docker)
chown -R www-data:www-data richdocuments

This presented a new issue. Nextcloud rejected the change and displayed the following error:

App update required
The following apps will be updated:

  • Nextcloud Office (richdocuments)
    Please make sure that the database, the config folder and the data folder have been backed up before proceeding.

I found out this could be averted by disabling richdocuments from the Applications menu on the Nextcloud Web UI (or occ) before changing the application files. You are then able to re-enable richdocuments once the package is unzipped.

Through trial-and-error with different versions of richdocuments, I found for Nextcloud 23.xx, the latest functional version is 5.0.6. Following this, Collabora was once again functional!

I hope you find this helpful