Disable SSL in loolwsd.xml

Hello,

i’ve installed CODE on debian 10 but i’m not getting it started. It fails with

File not found: /etc/loolwsd/ca-chain.cert.pem

How can i disable SSL in loolwsd.xml?

loolconfig set ssl.enable false

doesn’t work. It gives “No property, “ssl.enable”, found in config file.”

Best regards
blink182

You can just;

  • Open loolwsd.xml
  • Find this line:
    <enable type="bool" desc="Controls whether SSL encryption between browser and loolwsd is enabled (do not disable for production deployment). If default is false, must first be compiled with SSL support to enable." default="true">true</enable>
  • And change true to false like this:
    <enable type="bool" desc="Controls whether SSL encryption between browser and loolwsd is enabled (do not disable for production deployment). If default is false, must first be compiled with SSL support to enable." default="true">false</enable>

Thank you very much. But that didn’t work out for me.

The problem is that the CODE server is not reachable permamently via https. It seems it runs for a few seconds and then shuts down. Connections via Nextcloud always fail.

I used configuration no.2 from Setting up Nginx reverse proxy - Collabora Office and Collabora Online and set up nginx with a Let’s Encrypt certificate.

When i use

wget http://admin:mypass@locahost:9980

on the server i can access the admin interface properly.

Any hints?