Escaping allowed_languages for docker extra_params

What is the correct way of escaping the allowed_languages when overriding them with docker?

in the docker_compose.yml, I have tried the following

  • extra_params=–o:allowed_languages=de_CH de_DE en_GB en_US fr_CH fr_FR it
  • extra_params=–o:allowed_languages=de_CH\ de_DE\ en_GB\ en_US\ fr_CH\ fr_FR\ it
  • extra_params=–o:allowed_languages=“de_CH de_DE en_GB en_US fr_CH fr_FR it”
  • extra_params=–o:“allowed_languages=de_CH de_DE en_GB en_US fr_CH fr_FR it”
  • extra_params="–o:allowed_languages=de_CH de_DE en_GB en_US fr_CH fr_FR it"
  • extra_params=–o:allowed_languages=de_CH,de_DE,en_GB,en_US,fr_CH,fr_FR,it

Typically, this resulted in either on “de_DE” being recognized or the default languages being used.

How do we need to escape values with spaces? What kind of unescaping is being used?


Hi @MarcelW I think you need to set it via dictionaries environment variable rather than extra_params

SDK > Docker image: setting the application configuration dynamically via environment-variables

so probably something like -e 'dictionaries=e_CH de_DE en_GB en_US fr_CH fr_FR it' will work (?) let me know

1 Like

Great, thanks! I added - dictionaires=de_CH de_DE … to the docker-compse.yml environment:, and it worked!

(Sorry, I should have read the documentation more closely. But as essentially anything else in the configuration file is changed through the extra_params, …)

1 Like

No worries : ) I’m glad it worked!