Collabora CODE (with seafile) default language

Hi there,

I’m using seafile and collabora together in dockers on my raspberry pi 4 and it’s working great.
One problem though, I can’t seem to set the default language for my documents (spreadsheets specifically) so all the dates appear in the american format when I’m a UK user.

As mentioned here:
https://sdk.collaboraonline.com/docs/installation/CODE_Docker_image.html#setting-the-application-configuration-dynamically-via-environment-variables

I have tried to set the dictionaries environment variable within the collabora docker-compose:
But this doesn’t seem to have worked. Though I’m not convinced this is the right option to change?

- "dictionaries=en_GB"

If I change the default of a particular spreadsheet it seems to remember it from then on, but I want this changed for all spreadsheets by default.

I’ve searched around and don’t seem to be able to find the solution to this.

Any advice?

This depends on where the new file templates are coming from. I haven’t heard much about SeaFile recently, so I would assume they are not using the TemplateSource parameter to pass an actual template file for instantiation.

I’d expect there are some initial empty ODF (or MSO?) files somewhere in SeaFile that have US English locale set.
Language might also affect this, make sure you have UK English set in SeaFile. Again, I’m not sure if it’s passed through to CODE correctly.

Thanks for the reply, I’ve seen talk of these elsewhere (where people have found a similar problem with Nextcloud integration). I’ll try to take a look for this.

This problem exists on existing documents though, ones that started their life as google documents and got exported. As far as I know this problem didn’t exist in the google doc or when I’d exported them and just used them in LibreOffice (before I moved to using Seafile and Collabora CODE).