Nextcloud 23 Unable to open Collabora on some users


Im using Collabora Online latest version on my nextcloud server, but i have a problem with 1 specific user who is unable to open colabora, i tried 3 other diferent users they all can use it without any issues, but just one user when she creates a new document or try to open one, it just stays on the loading screen and never loads the document, im seeking for help to fix this cause its driving me cracy and i dont have any restriction on my server to use it :S

Hi @Javito1081 and thanks for reporting this. And is this problem only experienced in her side? And which browser is she using?

Could please paste here what you see when accessing the Network tab in the web dev tools?

  1. ctrl + shift + i or simply F12
  2. Select Network tab
  3. probably you need to reload the page now

Is there any error anything that doesn’t load or keep forever trying to load?

Also maybe it would help if you paste here your console errors:

  1. ctrl + shift + i or simply F12
  2. Select Console tab
  3. You can filter by Errors only ( by deselecting all the others Warnings, logs, Info,Debug

Is she using firefox with adblock or privacy badger installed? Could be the same issue as me.

The solution was to disable adblock for my Nextcloud domain.

here are the 2 screen you requested, i tried on her computer using chrome on both and the same issue occurs, but it only happens with that user, every other user is working fine, at least the other 5 i tested included myself out of 34, everyone can work with collabora just fine, but she cant :frowning:

and here is the network tab

nope, none of that, in fact i tried on 2 different pcs using chrome

Oh well, good luck in that case!

Here is a screen of the console tab when i filter by errors only, the last entry is the one that pops when i try to open a document

no one who can help me? :frowning: :frowning:

Hi @Javito1081 and thanks for the screenshots, I’m still missing the screenshot of the network tab. Since you are using chrome :

Meanwhile I’m trying to ask around if anyone has a clue of what it could be the culprit, but I have nothing additional to add here :confused: sorry. Please upload the missing screenshot and maybe there will be some clue of what is happening there.

and if you can (maybe it’s not needed, depending on how it will look your network tab’s screenshot) please add what you see in your coolwsd.log

lol ur right, i though i sent it to ya but i was wrong, here it is

and this is what i get after a min or so

where is this one located? cause i tried looking for it on /var/log but its not there

What does the journalctl -u coolwsd show? From the SDK documentation

1 Like

Have you tried sharing a file with this person, whether it fails to open that as well?

this is the screen of what i got from journal

yup it fails as well :frowning:

r u still arround pedro?