Saving Does Not Work on Android App for Downloaded DOCX Files

I am trying to use Collabora on my Samsung Galaxy Tab s7+ tablet but keep having the strangest issue. Whenever I open a Word document (*.docx) file and choose to edit it, I am able to edit, and then I tap the Save icon. Something seems to happen, but when I close out and then reopen the same file, any changes I have made are completely gone. I saw somewhere on Reddit (I think) that it will work if you choose Save As instead of Save, but that does not make sense to me and adds extra steps. Can Collabora not save changes to *.docx files? By the way, I have tried using the version in the Play Store, as well as collabora-office-mobile-6.4-snapshot-arm64-v8a-2022-04-22.apk and collabora-office-mobile-21.11-snapshot-arm64-v8a-2022-04-30.apk found at Index of /downloads/Collabora-Office-Android-Snapshot. Same issue with all of them. Any help is greatly appreciated!

Is this problem specific to DOCX files, or happens with others as well? (eg. ODT, XLSX etc.)
Are you opening the files from Collabora Office, or using Samsung’s file manager app?

I have not tried it with any other file type, but I can go and do that this afternoon and report back. I have been opening the files from Collabora Office directly, as I am not a huge fan of Samsung’s file manager app.

Okay, so legit I just tried again and it worked!! The only thing I can think of is that maybe I did not open the file from Collabora and instead I must have opened it from the Samsung My Files app. I am so sorry for my confusion with this and appreciate your patience. Do you happen to know if a different file app (like the Google one or something else) will work, or should I just stick with opening the files in Collabora (which I am totally fine with)?

There’s a known issue when using the Samsung My Files app, it might be fine with other file managers, because they’re all quite different.