Tabs of ODS document disappeared after Nextcloud update

I contribute here since it took me the whole evening to figure out what was going wrong and I did find no direct answer to my initial problem anywhere on the web.

Here is my story
A week ago I did a lot of update on my server. I updated Debian from 10 to 11, php from 7.3 to 8.0, nextcloud from 20.* to 23.0.whatever, etc… Collabora runs from a docker image with reverse proxy.
All was apparently working fine until one of my users noticed that Collabora Online would not show Calc documents tabs. It would only show the active tab.
Well, I looked into the logs and found no critic error beside some weird warnings.
So I decided to just completely reload my docker configuration:
mv /var/lib/docker /var/lib/docker.bak service docker restart docker pull collabora/code docker run -t -d -p -e 'domain=my\\.domain1\\.wat|my\\.domain2\\.the|my\\.domain3\\.fuk' --restart always --cap-add MKNOD collabora/code
When I did this, collabora would completely stop working. Instead of opening the LO files, they were downloaded to my computer.
Later I figured out (CODE Docker image — SDK documentation)
that the docker run command had to be updated. I then changed it to
docker run -t -d -p -e "aliasgroup1=https://my\\.domain0\\.wat:443,https://my\\.otherdomain\\.the|my\\.alias\\.fuk:443" --restart always --cap-add MKNOD collabora/code
Yet, the collabora server was correctly running on port 9980 but the document would not open. I kept landing on the depressing “failed to load document. Try later” page. And I still could not find any errors in the logs.
It then took me 2 whole hours to finally find out that the proxy configuration had changed. In your /etc/apache2/sites-available/ you want to replace every occurence of loleaflet with browser and every occurence of lool with cool in order to obtain a VirtualHost config as stated in this page : Proxy settings — SDK documentation

Once you have made all this changes, your are all set to enjoy your calc document tabs and the new appearance of the latest version of Collabora.

Welcome to the forum @Adam!

This is a known problem in some browsers when using <use_integration_theme>. It has been fixed and the fix should already be available :slight_smile: meanwhile, and if you don;t want to update now, you can set that to false within the coolwsd.xml file

Og I see that the previous problem you reported, even though similar, was not related to that GH issue. I’m glad you are able to enjoy with Collabora Online now :slight_smile:

Also worth to mention to anyone interested in migrating from old version that they can use the migration tool
man man/coolconfig.1` :

       The migrateconfig command migrates config file of Collabora Online 6.4 or older to the new format.

       migrateconfig [--old-config-file=<path>] [--config-file=<path>] [--write]

       --old-config-file=path    Specify file path for the old configuration manually. The default is /etc/loolwsd/loolwsd.xml.

       --write                   Write migrated configuration. Without this option no changes are written to the config file, only information about differences between old and new config is printed.

       Example: coolconfig migrateconfig --old-config-file=/etc/loolwsd/loolwsd.xml --config-file=/etc/coolwsd/coolwsd.xml --write