Can't print from Collabora on Chrome OS?

I talked my mother into getting a Chromebook to replace her old Windows 7 laptop and I’m trying to set it up for her. Had a hard time getting it to work with her printer which is too old to work off the network. I got it working by telling Chrome OS it was an HP and then trying similar sounding printer drivers until one worked so we can now print from Chrome.

Collabora will be her main app for word processing but it seems to have its own printer dialogue which doesn’t see the printer I set up. The only options in the printer dialogue are print to PDF and search for printers. Print to PDF works as expected but search just hangs.

Do I have to do something with Collabora to tell it what printers are installed?

Odd! More info might increase the chance of a solution: Is the printer connected via USB? What is the actual model of the HP? What model name did you choose? What’s listed in “Settings > Saved Printers”? if you edit the printer in Saved Printers what are the details listed in there?

Like you, I would have thought that if it appears in “Settings > Saved Printers” and it prints from Chrome then it should print from Collabora. Have you seen these links: Google’s Chromebook help: Set up your printer, HP printer setup (Chromebook), HP supported printer models

Thanks @rpear.Sorry for the delay but I just got over to look now.

It’s connected by USB.

The printer is an HP Laserjet M1212nf MFP and the driver I chose was HP Laserjet M125. That was the first one I tried that resulted in anything printing.

Under edit printer I see:

Name: Hewlet-Packard HP LaserJet Professional M1212nf MFP (USB)
Address: 03f0
Protocol: USB
Queue: 052a?serial=000000000QJ61L8JPR1a
URI: usb://03f0/0p52a?serial=000000000QJ61L8JPR1a
Manufacture: HP
Model: HP Laserjet Pro Mfp M125A

No guarantee that I got the right number of 0s

There was no popup when I first plugged in the printer but I was able to use the dialogue to create a saved printer as described.

I’m going through your links now but mostly just getting confused. There was promising talk about using HP Linux Imaging and Printing (HPLIP) but it’s not in play store and seems to be a linux package. Can it used with chrome os?

Hi Jim, I had a quick look at HP’s supported printer models, the “HP LaserJet m1210 MFP Series” is the best match. It looks like it has full support with Chromebooks with both USB and network. It shows that the Laserjet M125 is quite different and doesn’t support Chromebooks or network.

Tip: If you try to print to a printer using the wrong driver it is sometimes necessary to power the printer off and on to clear out bad data which can block future print jobs.

Did you know you can remote control your mums Chromebook using “Chrome Remote Desktop”? You need to install the extension on both computers: Chrome > Menu > More Tools > Extensions > search for “Chrome Remote Desktop”. When you need to remote control, you and your mum both need to go to (or click the jigsaw piece at the top right of Chrome) and follow your nose.

Thanks again and I will try tomorrow. Remote control sounds like a great idea.