CODE connecting 0%: cannot connect to ods-document / stops working

Since having upgraded to the latest code version 6.4.10 on ubuntu/nextcloud with LAMP-stack / nextcloud app, sometime a document cannot be worked on any more.
The can be resolved by either restarting nextcloud or by

  1. downloading the file
  2. rename the original file in nextcloud
  3. upload the downloaded file (using the original name) to nextcloud

Accessing the uploades file will work. Accessing the renamed file does not work.

The text says: (CODE) Verbinden… 0%

Any ideas why this happens and how to avoid it?

Thanks!

Martin

Experiencing the same issue with [6.4.10.5], but not with [6.4.10.4]
Try pulling collabora/code:6.4.10.4 instead of latest.

Just pulled [6.4.10.6] and everything seems to be working fine.

6.4.10.4 runs much better that 6.4.10.3, but we experience the above described error approximatly twice a week. Didn’t test 6.4.10.6

6.4.10.6 has this fix in it, does it fix it for you?

We use an inhouse setup with plain http while testing.

So SSL/TLS/SNI-code should not be involved.

Hi everyone,
may issue is that I do not use docker.
How can I change or rollback to previous version?

this is how I get the Collobora/code
echo ‘deb Index of /repos/CollaboraOnline/CODE-ubuntu2004 ./’ | sudo tee /etc/apt/sources.list.d/collabora.list

Tried CODE Server 6.4.10.10 with Nextcloud 21 but it does not work. Apparantly Collabora is not interested to solve the problem. Any ideas?

@MVZ-LRA, do you still experience this issue with the latest CODE version?

Please, anyone else who’s having a similar issue should kindly start a new thread, and then, take and upload trace-level logs from LOOLWSD.

1 Like

Welcome @harley-peter , maybe the better course of action is indeed creating a new thread as pointed by @Ezinne . It seems we might be talking about different root issues within different versions. Please create a new one with:

  • Your setup info
  • Versions

Thanks and sorry for the delayed response,
(meanwhile I will try to chase someone who can look into this further)

1 Like

Hi Ezinne,
we have this issue about once a week.
Workaound is:
-Duplicate file
-remove original file
-move copy back to original.

Sometime the CPU-load rises to 100%. In this case we do a server reboot. This is possible in our environment because only one file is edited at the same time.