Collabora built-in code server in NC 25 docker raspberry pi 4 doesn't work

Hey, I have installed NC in raspberry pi 4 using docker and after the setup, it asked me to install recommended apps and I installed all those apps which also include Collabora office. However, after setting up everything, when I tried to open/edit the empty doc file which I have created, it does not open the file to edit it, instead, it just start downloading the file. I also tried to re-install the Collabora app but no luck!!!
Any help would be appreciated. Thank You very much

I am bumping this; I am having the same issues. I posted an issue about it on Nextcloud’s community page, and I’m gonna paste the same documentation here:

Nextcloud version: 25.0.2
Operating system and version: Ubuntu 22.04 LTS
Apache or nginx version: 2.4.54
PHP version: 8.1.3

The issue you are facing:

I have a Nextcloud instance with the Built In CODE server installed. It used to work, but I didn’t use it for a while, and now when I click a document to edit, it downloads instead of edits. If I select a file and click the “…” to look for options, there is no edit option or anything to indicate opening in CODE. It’s like Nextcloud doesn’t see the built in CODE server and functions normally as if it doesn’t exist.

If I go to Administration and find the “Nextcloud Office” pane, I can see the radio button for “Use the built-in CODE - Collabora Online Development Edition” is checked, and above that I have a green check for “Collabora Online server is reachable”.

There is nothing in the logs, neither a warning nor error. I’ve also checked the apache error and access logs, nothing there either. I’m not sure where else to look.

Is this the first time you’ve seen this error? : Yes

Steps to replicate it:

  1. Go to Files, find a document
  2. Click it.
  3. A download dialog from the browser pops up

The output of your Nextcloud log in Admin > Logging:

Absolutely no log entries at any severity including Debug show up for this action.  There are previous warnings in the logs not related to this issue.

The output of your config.php file in /path/to/nextcloud:

$CONFIG = array (
  'instanceid' => '------------------',
  'passwordsalt' => '--------------',
  'secret' => '-------------------',
  'trusted_domains' =>
  array (
    0 => '',
    1 => '',
    2 => '',
  'datadirectory' => '/var/www/nextcloud/data',
  'dbtype' => 'mysql',
  'defaultapp' => 'files',
  'version' => '',
  'overwritehost' => '',
  'overwritewebroot' => '',
  'overwriteprotocol' => 'https',
  'overwrite.cli.url' => '',
  'htaccess.RewriteBase' => '/',
  'dbname' => 'hda_nextcloud',
  'dbhost' => 'localhost:3306',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'usr_servername_nextcloud',
  'dbpassword' => '--------',
  'installed' => true,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'maintenance' => false,
  'theme' => '',
  'log_type' => 'file',
  'logfile' => '/var/log/nextcloud/nextcloud.log',
  'loglevel' => 2,
  'mail_from_address' => 'nextcloud',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => '',
  'mail_smtphost' => '',
  'mail_smtpport' => '25',
  'default_phone_region' => 'US',
  'ldapProviderFactory' => 'OCA\\User_LDAP\\LDAPProviderFactory',
  'app_install_overwrite' =>
  array (
    0 => 'files_3d',
    1 => 'files_texteditor',
    2 => 'printer',
    3 => 'epubreader',
  'trashbin_retention_obligation' => 'auto,15',
  'allow_local_remote_servers' => true,

The output of your Apache/nginx/system log in /var/log/____:

There is basically nothing, this is the output of multitail -f --mergeall /var/log/apache2/error.nextcloud.log /var/log/apache2/access.nextcloud.log during a click of a document

*.93.213.50 - - [16/Dec/2022:12:52:29 -0800] "PUT /ocs/v2.php/apps/user_status/api/v1/heartbeat?format=json HTTP/1.1" 200 1645 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:107.0) Gecko/20100101 Fire
fox/107.0" - username [16/Dec/2022:12:52:34 -0800] "PROPFIND /remote.php/dav/files/0c904fda-590e-103b-8ab3-8f73b30b6c02/Mike HTTP/1.1" 207 5466 "-" "Mozilla/5.0 (Windows) mirall/3.4.0stable-Win64 (b
uild 20211129) (Nextcloud, windows-10.0.22621 ClientArchitecture: x86_64 OsArchitecture: x86_64)"
*.93.213.50 - - [16/Dec/2022:12:52:35 -0800] "PUT /ocs/v2.php/apps/user_status/api/v1/heartbeat?format=json HTTP/1.1" 200 1645 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:107.0) Gecko/20100101 Fire
*.93.213.50 - - [16/Dec/2022:12:52:35 -0800] "PUT /ocs/v2.php/apps/user_status/api/v1/heartbeat?format=json HTTP/1.1" 200 1039 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:107.0) Gecko/20100101 Fire
*.93.213.50 - - [16/Dec/2022:12:52:36 -0800] "GET /remote.php/webdav/Home/Documents/Philosophy.doc HTTP/1.1" 200 26212 "-" "Mozilla/5.0 (Windows NT
10.0; Win64; x64; rv:107.0) Gecko/20100101 Firefox/107.0"
*.93.213.50 - - [16/Dec/2022:12:52:18 -0800] "GET /apps/logreader/poll?lastReqId=5OEiTeYJMUgAQcMsN6xY HTTP/1.1" 200 918 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:107.0) Gecko/20100101 Firefox/107

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

No errors in nextcloud.log


Question regarding Nextcloud built-in CODE server are better asked on

Multiple users reported dysfunctional integrated CODE there. I can’t tell much about the issue itself as I run CODE as separated docker container (if you run docker there is now advantage in using Nextcloud integrated CODE). Multiple users successfully integrated separated CODE using docker.

In general Raspi has computing power so you may have hard time trying to setup Nextcloud and CODE on such device…