Collabora + Nextcloud -> Image -> Insert Image

Hello,

It seems I can’t find a solution to my issue.

Nextcloud works as it should.
Colabora also works as it should.

The only thing that trows errors in Browser console (Nothing on screen) is when you try to insert picture from Nextcloud.

  1. When you press Image->Insert Image in colabora it displays images and you can browse folders.
  2. You can also upload images directly from PC to colabora and it works without any problems.

When you insert picture from Nextcloud in Console you get error:

GET https://files.example.com/apps/richdocuments/assets/ 404 (Not Found) → FilesAppIntegration.js:176

Uncought (in promise):
z {message: ‘Request failed with status code 404’, name ‘AxiosError’, code: ‘ERR_BAD_REQUEST’ } FilesAppIntegration.js:177

It references code:

	const insertFileFromPath = async (path) => {
		const filename = path.substring(path.lastIndexOf('/') + 1)
		const { data } = await axios.post(generateUrl('apps/richdocuments/assets'), { path })
		insertFile(filename, data.url)
	}

Any suggestions?

Curl / TLS works for both domains from colabora->nextcloud from nextcloud->colabora.
No WOPI limitations set for debugging in nextcloud.

NC version: 29.0.0
CB version 24.04.2.1

Webserver Nginx + SSL termination (copy from Colabora website).
Colabora separate domain
Nextcloud separate domain

Errors in docker log:

I can provide more information - I really want to solve this.

Hi njscop,

Welcome here :sun_with_face:

Thanks for reporting. I noticed similar some time ago,

and also that it works OK for us in 24.04.4…
Is it possible for you to test that?
Thnks also for your clear reporting!
Cor

cornouws - I will test it immediately.

1 Like

So I could not find docker 24.04.4 version where should I download it?
But I installed older 23.05.10. 1.1 and got the same error.

When the image insertion succeeds, on JS debug console I see:
1716288411769 OUTGOING: insertfile name=https%3A%2F%2Fshare.collabora.com%2Findex.php%2Fapps%2Frichdocuments%2Fassets%2FTAmV8vyGjAZAht0i7dCSWfItGMX6zPkAmE9BmR2fBpNagNkpDy366dCZCn5BxPDo type=graphicurl
Then the coolwsd server downloads the image from Nextcloud
Your screenshot shows unrelated error messages (missing icons on user interface).
You can check if you see the insertfile command (Ctrl+Shift+Alt+D and Log outgoing messages), and try to curl that URL. There must be some routing or permission problem.

Ok so I got the console working.

But when inserting picture from Nextcloud the same error:

GET https://files.example.com/apps/richdocuments/assets/ 404 (Not Found)

Nothing else on console.

Doing other things I do get INCOMING delta …