Copy the results of functions in cells, not the functions themselves

I only found one previous post about this issue, but the answer there was to use a special paste.

I have this problem…
I have cells in Calc that contains functions, concat of fields. I want to copy this and use it outside of Calc, e.g. Notepad.
If I copy using CTRL-C I get the functions, not the results of the functions.

I have tried different combos of keys e.g. SHIFT-CTRL-C, CTRL-ALT-C, SHIFT-CTRL-ALT-C but none worked.

In LibreOffice this works perfectly (and Collabora still builds on LibreOffice, huh!?) but not in Collabora Calc.

I am grateful for any kind of hints that can lead to a solution. I just upgraded from 6.4 to 22.x in the hope that this would solve it, but unfortunately not. Does it require the latest version of NextCloud by any chance (I am not running the CODE server).


Hi OptiBiz,

Thanks for the clear description of your problem!
You are facing the fact that the clipboard on the desktop is not similar the clipboard in the browser…
So unless a new feature would be developed, allowing to copy cell values, I only see a workaround for you: copy&paste-special inside COOL and from there…

This aside, IMO Collabora Online does a really great job with copy&pasting :wink:


1 Like

Thank you for your answer. After searching for a solution online, I finally did something drastic. I asked ChatGPT, believe it or not. :slight_smile: I got an answer, I actually got several answers, some that didn’t work. After testing it, it worked with some tweaking. It’s not a good solution, but it worked.

  1. Copy all the cells in e.g. a column
  2. Place the cursor on the cell where you want to paste the content (without the functions)
  3. Press the Insert key (not CTRL-Z), choose Value only.
  4. Copy the new column to outside of Collabora Online Calc

There is of course the option to download it externally, then use LibreOffice etc to copy the cells with the functions, but that’s even worse as a solution.

Thank you for your answer, @cornouws .


Thanks for posting the current workaround @OptiBiz1.

And how do you accomplish the same thing in LibreOffice?

You may also be interested in following this feature request:

(I mentioned this thread + posted a link back here just now.)

Side Note: You may also be interested in this talk:

where Michael describes all the horrors of copying/pasting:

  • in-and-out of browsers
  • + on different OSes
  • + between programs

… boy, oh boy, is it ugly. :stuck_out_tongue:

I also wrote about it a little here 1 year ago too:

Hey @OptiBiz1,

This is now fixed in the next release of Collabora Office: