Disable save on exit


When a user close a doc, I launch a def generation automatically.
To do this, I use the last put message (Header X-Lool-Wopi-Isexitsave=true).
The parameter “always_save_on_exit default” is set to true but when a user save the doc and close it quickly (2-3 sec) → the put message is not sent (is it a bug ?) !
So, I’d want to use the unlock message but without save on exit. Is there a way to completely disable the save on exit and may be a pretty message if the doc has not been saved ?


Interesting and thanks for reporting this back!

if this is true: <always_save_on_exit desc="On exiting the last editor, always perform the save, even if the document is not modified." type="bool" default="false">false</always_save_on_exit> I think you might be right it might be a bug