Error 400 Bad Request URL Too Long

Good morning
I have a problem when I try to access documents in a cloud with a tree structure that is too large.
When I’m in a folder that has a 380 character request it works, and when I go to 410 I get a 400 Bad Request error on Collabora/code.
I’m on kubernetes with the latest version of Collabora/Code.
I tried in my Ingress-Nginx to add maxurllength but it didn’t change anything.
Do you have an idea ?

@Loubens can you give some steps to reproduce the problem please ?

@rash419 Good morning
when I try to create a file in a folder, and that folder is in a subfolder, which is in a subfolder, etc…
I can create my file in my cloud without worries, I can download it if needed, however I can’t open it from Collabora/code, here is the length of my WOPI request: WEUxdmJpQmpiRzkxWkNCUVpYSnpiMXhOYjI0Z1kyeHZkV1FnVUdWeWMyOGdNbHhOYjI0Z1EyeHZkV1FnVUdWeWMyOGdNMXhOYjI0Z1kyeHZkV1FnTkZ4TmIyNGdZMnh2ZFdRZ05WeE5iMjRnUT J4dmRXUWdVR1Z5YzI4Z05seDBaWE4wSUdOc2IzVmtJRE11Wkc5amVBPT0=
And when I do that, I get a 400 error.
Is that enough information?
Otherwise the other question is:
What is the MAX URL length for Collabora/code?

Good morning
I found a solution, I did an MD5 HASH of my files path in my WOPI call, and now it works.

Glad that works for you; I’m surprised it caused an issue - we don’t have an internal limit on WOPISRC length that I’m aware of; but I can believe that proxies the connection goes through may do.

Ultimately any unique hash we can provide back to you to uniquely identify the file should work I hope. Thanks for asking.