Owncloud get stuck during opening file / connecting process

Hello dear fellows,

I have problems regarding the connection / opening process of a document in my owncloud.


  • Ubuntu Server 20.04.4
  • owncloud Version
  • owncloud richdocuments app 2.7.0
  • NGINX 1.18.0
  • latest installation of coolwsd & collabora-online-brand package

The owncloud server is running on the same machine as the coolwsd-service. The owncloud instance is reachable throught reverse proxing of NGINX over https://cloud.***.de and the coolwsd-service over https://collaboraonline.***.de.


owncloud: in the app settings of richdocuments the https://collaboraonline.***.de is set
coolwsd: the interessteing part of the config (I guess):

<storage desc="Backend storage">
    <filesystem allow="false" />
    <wopi desc="Allow/deny wopi storage." allow="true">
        <max_file_size desc="Maximum document size in bytes to load. 0 for unlimited." type="uint">0</max_file_size>
        <locking desc="Locking settings">
            <refresh desc="How frequently we should re-acquire a lock with the storage server, in seconds (default 15 mins) or 0 for no refresh" type="int" default="900">900</refresh>

        <alias_groups desc="default mode is 'first' it allows only the first host when groups are not defined. set mode to 'groups' and define group to allow multiple host and its aliases" mode="groups">
                <host desc="hostname to allow or deny." allow="true">https://cloud.***.de:443</host>


When I try to open a document in the owncloud-ui, it says " initialization", then “failed to connect to server” and then it get stuck at 0% trying to connect. On the same side the coolwsd-service logs:

wsd-01809-02370 2022-04-12 14:24:13.611525 +0200 [ docbroker_003 ] ERR  #26: read failed, have 0 buffered bytes (EPIPE: Broken pipe)| ./net/Socket.hpp:1123
wsd-01809-02370 2022-04-12 14:24:13.611682 +0200 [ docbroker_003 ] ERR  #26: Socket write returned -1 (EPIPE: Broken pipe)| ./net/Socket.hpp:1401
wsd-01809-02370 2022-04-12 14:24:13.611733 +0200 [ docbroker_003 ] ERR  #26: Socket write returned -1 (EPIPE: Broken pipe)| ./net/Socket.hpp:1401
wsd-01809-02370 2022-04-12 14:24:13.611837 +0200 [ docbroker_003 ] ERR  WOPI::CheckFileInfo failed for URI [https://cloud.***.de/owncloud/index.php/apps/richdocuments/wopi/files/200_ocw05i95inzu_0_0?access_token=ctAqlr1ft2HAJRubKqFxmEc56cTnCkdg&access_token_ttl=1649802249000]: 0 . Headers:         Body: []| wsd/Storage.cpp:675
wsd-01809-02370 2022-04-12 14:24:13.611938 +0200 [ docbroker_003 ] ERR  loading document exception: WOPI::CheckFileInfo failed: | wsd/DocumentBroker.cpp:2145
wsd-01809-02370 2022-04-12 14:24:13.611992 +0200 [ docbroker_003 ] ERR  Failed to add session to [https://cloud.***.de:443/owncloud/index.php/apps/richdocuments/wopi/files/200_ocw05i95inzu_0_0] with URI [https://cloud.***.de/owncloud/index.php/apps/richdocuments/wopi/files/200_ocw05i95inzu_0_0?access_token=ctAqlr1ft2HAJRubKqFxmEc56cTnCkdg&access_token_ttl=1649802249000]: WOPI::CheckFileInfo failed: | wsd/DocumentBroker.cpp:2107
wsd-01809-02370 2022-04-12 14:24:13.612047 +0200 [ docbroker_003 ] ERR  Storage error while starting session on https://cloud.***.de:443/owncloud/index.php/apps/richdocuments/wopi/files/200_ocw05i95inzu_0_0 for socket #19. Terminating connection. Error: WOPI::CheckFileInfo failed: | wsd/COOLWSD.cpp:4081
wsd-01809-02370 2022-04-12 14:24:13.612303 +0200 [ docbroker_003 ] WRN  Ignoring attempted read from 19| ./net/Socket.hpp:1102
wsd-01809-02370 2022-04-12 14:24:13.612343 +0200 [ docbroker_003 ] ERR  Invalid or unknown session [007] to remove.| wsd/DocumentBroker.cpp:2190
wsd-01809-01832 2022-04-12 14:24:13.648507 +0200 [ websrv_poll ] WRN  DocBroker with docKey [https://cloud.***.de:443/owncloud/index.php/apps/richdocuments/wopi/files/200_ocw05i95inzu_0_0] is unloading. Rejecting client request to load.| wsd/COOLWSD.cpp:2670
wsd-01809-01832 2022-04-12 14:24:13.648718 +0200 [ websrv_poll ] ERR  Error while handling Client WS Request: Failed to create DocBroker with docKey [https://cloud.***.de:443/owncloud/index.php/apps/richdocuments/wopi/files/200_ocw05i95inzu_0_0].| wsd/COOLWSD.cpp:4114
wsd-01809-01832 2022-04-12 14:24:13.648767 +0200 [ websrv_poll ] WRN  #19 is shutting down but 64 bytes couldn't be flushed and still remain in the output buffer.| ./net/WebSocketHandler.hpp:793
wsd-01809-01832 2022-04-12 14:24:13.648813 +0200 [ websrv_poll ] ERR  #19: attempted to remove: 904 which is > size: 0 clamped to 0| ./net/Socket.hpp:1223
wsd-01809-01832 2022-04-12 14:24:13.648854 +0200 [ websrv_poll ] WRN  Ignoring attempted read from 19| ./net/Socket.hpp:1102
wsd-01809-01832 2022-04-12 14:24:13.648953 +0200 [ websrv_poll ] ERR  #19 Error while handling poll at 0 in websrv_poll: #19BIO error: 337690831, rc: -1: error:1420C0CF:SSL routines:ssl_write_internal:protocol is shutdown:
140588686464768:error:1420C0CF:SSL routines:ssl_write_internal:protocol is shutdown:../ssl/ssl_lib.c:1931:

I know that there are some tickets around here, regarding the multihost setting with the same problem discription. But I tried everything what is written there. If you have any idea what is wrong here, I would be very happy to hear it. If you need any further informations, please let me know!

Thank you in advance!

Welcome @JelmenGuhlke and thanks for tacking the time to create this topic!

Are you using the linux packages or via docker?

@rash419 do you think this is related to the latest changes on multiple host configuration? it seems different from the other reports we have here in the forum

If you search can you find this error log ?
No acceptable WOPI hosts found matching the target host

@pedro.silva @rash419 thanks for your quick reply!

  1. I use the linux package; not the docker image
  2. I had the message “No acceptable WOPI hosts found matching the target host” during my first tries. But after I changed the config to the written above, the message was not printed anymore. The error-logs repeat a few times.

Thank you for your thoughts!

1 Like

no problem : )
So does it work now? (After changing the config?)

@pedro.silva no, sadly still doesnt work. Same error log as above written