Proxy/collabora/nextcloud on different servers

Hi All,

I have nextcoud, collabora, and an nginx proxy servers running on three different vms on a KVM host server. All ubuntu servers

The nginx proxy is also serving the letsencrypt certs.

Nextcloud and proxy are existing and functioning correctly.

Trying to add collabora docker server to the vms.

I seem to be screwing up the nginx conf files on both the proxy and collabora servers

Does anyone have sample working nginx conf files for both servers that I can use as a guide to ?

When I type in the IP address of collabora server into my laptop browser, I get the default nginx page, when I type in the https domain name that I have assigned for it, I get “ERR_TOO_MANY_REDIRECTS” error



I think that I managed to figure out the conf file on the proxy server, because now I am getting the default nginx conf file from the collabora server, now when I type in the domain name.

I believe that I have to figure out the collabora server nginx conf file.

If someone has a sample that I can use to create one, that would be great.

Also, which nginx folder do I put it in?


Hey @ijeoijwoeic2eij2. Welcome to the forum. :slight_smile:

Have you tried following the instructions:

There is also this fantastic Nextcloud “Wiki” topic that might help:

They go into even more testing between Nextcloud<->Collabora + proxies/troubleshooting things. :slight_smile:

Might also help if you can give exact version numbers too of:

  • Collabora Online + richdocuments
  • Nextcloud
  • Your OS + OS version
  • […]

Great! Sounds like one step in the right direction! :slight_smile:

Hi Thank you, Tex, for the help so far:

3 Servers, all Ubuntu22LTS

Nextcloud Server: NC29.0.1/ NGINX,

Collabora (NonDocker) Server: Presuming 24.04, brand new fresh install

NGINX Proxy Server:

Been using this link as a troubleshooting guide: Collabora integration guide - Wiki - Nextcloud community

By the looks of it, everything is installed correctly, can access all the test urls from curl of all servers and browsers.

Have the green checkmark on Admin->Office, for the wopi ip address, I am using the LAN subnet

I am thinking that the /etc/coolwsd/coolwsd.xml config file group/alias is not setup correctly (maybe?), don’t know if that would be the cause

<wopi allow="true" desc="Allow/deny wopi storage.">
                        <max_file_size desc="Maximum document size in bytes to load. 0 for unlimited." type="uint">0</max_file_size>
                        <locking desc="Locking settings">
                                <refresh default="900" desc="How frequently we should re-acquire a lock with the storage server, in seconds (default 15 mins) or 0 for no refresh" type="int">900</refresh>
                        <alias_groups desc="default mode is 'first' it allows only the first host when groups are not defined. set mode to 'groups' and define group to allow multiple host and its aliases"  mode="first">
                                <!-- If you need to use multiple wopi hosts, please change the mode to "groups" and
                    add the hosts below. add them as aliases. -->
                    <host desc="hostname to allow or deny." allow="true">scheme://hostname:port</host>
                    <alias desc="regex pattern of aliasname">scheme://aliasname1:port</alias>
                    <alias desc="regex pattern of aliasname">scheme://aliasname2:port</alias>

                                <!-- More "group"s possible here -->
                        <is_legacy_server default="false" desc="Set to true for legacy server that need deprecated headers." type="bool"/>

I have alias_groups set to first

My nextcloud is on the main domain (, the collabora is on the subdomain (