Raspberry Pi 4 "Could not establish connection to the Collabora Online server" but Nginx seems to be configured correctly

I have Nextcloud installed on a Raspberry Pi 4, via YunoHost, and then I installed the corresponding ARM64 version of the CODE server (richdocumentscode_arm64). When attempting to make CODE run, however, I’m shown the following notice:

Could not establish connection to the Collabora Online server. This might be due to a missing configuration of your web server. For more information, please visit: Connecting Collabora Online Single Click with Nginx

I followed the link, and it asks to edit the Nginx file to have the server correctly point to the CODE path - the problem is, YunoHost is apparently configured to do it already!

  location ~ ^/(?:index|remote|public|cron|core\/ajax\/update|status|ocs\/v[12]|updater\/.+|oc[ms]-provider\/.+|.+\/richdocumentscode\/proxy)\.php(?:$|\/) {
    fastcgi_split_path_info ^(.+?\.php)(\/.*|)$;
    set $path_info $fastcgi_path_info;
    try_files $fastcgi_script_name =404;
    include fastcgi_params;

    fastcgi_param SCRIPT_FILENAME $request_filename;
    fastcgi_param PATH_INFO $path_info;
    fastcgi_param HTTPS on;
    # Avoid sending the security headers twice
    fastcgi_param modHeadersAvailable true;
    # Enable pretty urls
    fastcgi_param front_controller_active true;
    fastcgi_pass unix:/var/run/php/php7.3-fpm-nextcloud.sock;
    fastcgi_intercept_errors on;
    fastcgi_request_buffering off;
  }

Is there anything else I’m supposed to modify here, or elsewhere? Is the fact that I installed richdocumentscode_arm64 instead of the normal richdocumentscode relevant to this case? (I already attempted to manually change the regex above to add the _arm64 instead, but to no avail)