"The requested URL was not found on this server." when moving from to

I tried to upgrade my docker from to [current latest].
I litterally just stopped and removed the previous installation, then pulled and installed the new one, with no other changes in any configuration on my server [Apache]
Everything worked fine wirh [and works fine if I revert back], but when I try to use I get: " Not Found - The requested URL was not found on this server."

Is there anything different within the docker that would cause that?

Still not sure why upgrading isn’t working for me.
I don’t change anything in my configurations, I just delete the old docker code and pull/install the new one.

If I try to connect to I get an “OK” message:

Screenshot 2022-01-07 at 17.19.46

… but if I trie to connect to nothing happens:

Any suggestions?

Hi @ivnmad I think this might be related with lol* files that were renamed to cool* (example: coolwsd.xml) and more important the old directory loleaflet is now named browser. Could you please try ?

Also please note that migration tool has been worked (thanks @bearon ) on very recently to assist people in their migrations:

Hi Pedro,

Thank you for the info.
If I got to the admin login window pops up, so that is good.
I then changed my reverse proxy from

ProxyPass /loleaflet retry=0
ProxyPassReverse /loleaflet


ProxyPass /browser retry=0
ProxyPassReverse /browser

I can reach the admin page via the domain as well, and I seems to be able to start opening a file, but I then get this:

Do I need to change something else in the reverse proxy?
This is the full script:

ProxyPass /browser retry=0
ProxyPassReverse /browser

ProxyPass /hosting/discovery retry=0
ProxyPassReverse /hosting/discovery

ProxyPassMatch “/lool/(.*)/ws$” wss://$1/ws nocanon

ProxyPass /lool/adminws wss://

ProxyPass /lool
ProxyPassReverse /lool

ProxyPass /hosting/capabilities retry=0
ProxyPassReverse /hosting/capabilities

Thank you again,


@ivnmad Yes, several more entries have to be changed, please see the following guide

Brilliant, followed the instructions [and bookmarked the page].
All working fine now. Thank you.