Track Changes not preserved in the file

Hello,
I am currently trying Collabora out for the first time. The function Track Changes does not work for me at the moment. When I set record & show changes, everything works exactly as expected, however, all the recordings dissappear when I close the file and reopen it.
This makes the function rather unusable, sadly. I don’t know if this is general behavior or just the case of my current collabora deployment. I am using Collabora Office 6.0-29 in combination with Nextcloud 21. I cannot try it out on other server at the moment. Thanks for any information and help.

Hi @Marian and thanks for testing that out. That should have worked. I have tested in quite similar (almost the some git hash) master branches from Collabora Online and in one instance it worked in another didn’t.

Collabora Online + Collabora Office 6.0-39 + NC

  • Using NC sync in both occasions
  • This makes be tend to believe that it might be richdocuments related but I need to test and confirm this

Just to confirm your steps (please let me know if this was what you did):

  • Open a file locally using Collabora Office
  • Turn on track changes and add some changes
  • Save and quit
  • Open again the file with Collabora Office and check that indeed those changes were recorded, close
  • check that the sync client uploaded that file
  • Open the same file this time in the browser via Collabora Online on Nextcloud
  • Track changes were not saved (even thought the Edit > Track Changes was on

Hi @pedro.silva,

Thank you for your support. As for my worklow: I was only using the Collabora Online Tool in my browser the whole time. That is,for creating of new file, setting track changes, editing, closing and re-opening (and the changes were not recorded). I do not have collabora office on my computer, so it was not part of the workflow.
But I was trying now to do something different: I have created an ODT-file locally with my libreoffice and then uploaded it to the NC. As it seems, I can edit it now with Collabora and the track changes function works properly! I don’t know what is the technical difference between ODT-file created originally by Collabora and the one created by Libreoffice?

Not much is different about an ODT created in one application or another. However, from this description it could be that the file you were editing might not have been an ODT file. It was probably a text file, because when you created a file in NC, it ended up being a 0-byte file due to this bug:

Then the 0-byte file was treated as a text file (the file format is identified based on the content of the file, not based on extension). Your Collabora Online version is very old (inferring from the Collabora Office 6.0-29 core part version number it was a 4.0 version), this issue is fixed in recent versions, the 0-byte file will be treated as an ODT/ODS/ODP as expected.
The Nextcloud bug is also supposed to be fixed in their development version.

1 Like