Unable to initiate connection to host listening on port 8443


I am running collabora-code as docker container using docker-compose.

The instance is intended to be used by 2 different nextcloud instances

a) cloud.domain.tld running on port 443
b) files.domain.tld running on port 8443

docker-compose file contains two aliasgroups

  • aliasgroup1=https:// cloud.domain.tld:443
  • aliasgroup2=https:// files.domain.tld:8443

(blank after https has only been inserted in this post)

NC collabora configuration on both instances display that the collabora server is reachable.

Integration with instance a) running on port 443 is running perfectly.

From instance b) running on port 8443 when trying to load a file from NC an error message is displayed.

Digging into collabora logging reveals these lines:

wsd-00001-00033 2024-03-24 10:58:03.081581 +0000 [ docbroker_001 ] WRN #30: Timed out while requesting [GET files.domain.tld/index.php/apps/richdocuments/wopi/files/3647213_xxx?access_token=xxx&access_token_ttl=0] after 30028ms| net/HttpRequest.hpp:1507

wsd-00001-00033 2024-03-24 10:58:03.081791 +0000 [ docbroker_001 ] ERR WOPI::CheckFileInfo failed for URI [https://files.domain.tld:8443/index.php/apps/richdocuments/wopi/files/3647213_xxx?access_token=xxx&access_token_ttl=0]: 0 (Unknown) . Headers: Body: | wsd/Storage.cpp:708

wsd-00001-00033 2024-03-24 10:58:03.081881 +0000 [ docbroker_001 ] ERR loading document exception: WOPI::CheckFileInfo failed: | wsd/DocumentBroker.cpp:2679

wsd-00001-00033 2024-03-24 10:58:03.081921 +0000 [ docbroker_001 ] ERR Failed to add session to [https%3A%2F%2Ffiles.domain.tld%3A8443%2Findex.php%2Fapps%2Frichdocuments%2Fwopi%2Ffiles%2F3647213_yyy] with URI [https://files.domain.tld:8443/index.php/apps/richdocuments/wopi/files/3647213_xxx?access_token=xxx&access_token_ttl=0]: WOPI::CheckFileInfo failed: | wsd/DocumentBroker.cpp:2641

wsd-00001-00033 2024-03-24 10:58:03.095717 +0000 [ docbroker_001 ] ERR #18: Read failed, have 0 buffered bytes (ECONNRESET: Connection reset by peer)| net/Socket.hpp:1137

The first log entry containing the GET request is missing the port 8443 in the URL. This looks suspicious to me.

Does anybody have an idea if I am missing any configuration settings to get integration working on a port other than 443?

1 Like

Hi @jowi, welcome to the forums! I see you’re experiencing integration problems with the CODE Docker image.

I have a question to help set up your integration configuration:

Have you added the alias group information inside the Multihost Configuration section of coolwsd.xml?

In the meantime, I’ll analyze the provided error logs and get back to you as soon as I find a solution.


Can you make sure you domains are reachable from CODE docker images ?
To find out:

  1. Exec in to the CODE container:
docker exec -it <containerid> bash
  1. Run curl command on your domains
curl -k "https://cloud.domain.tld:443"

Make sure they are accessible from the docker image.