Build with default language


I built Collabora CODE.
Additional translations have been made to under-translated parts, so all ribbon menus are now in Korean.
However, the sidepanel and popup are all displayed in English no matter which method you use.

What options can I give when building this part to make it appear in Korean?

Hello @kroid,

Welcome to the forum and thanks for your question. :slight_smile:

Currently, Collabora’s UI is only ~49% translated in Korean!

If you want to help better translate Collabora Online to your language, see:

You can also join the Weblate community (and see the status of all strings) here:

Volunteer translators—hopefully you!—and the Korean community have to help translate the that sidebar into Korean! :slight_smile:

Specifically for the sidebar - these translations come from the LibreOfficeKit core - so - perhaps you should install the relevant CollaboraOffice language-package for Korean ? - check your language is in <allowed_languages> in coolwsd.xml - and/or please do help to contribute to LibreOffice translation: Translating LibreOffice - The Document Foundation Wiki also done using weblate :slight_smile:

Thanks for contributing and being part of the solution!

1 Like

Hello. Thank you for reply!

I know most Korean is not translated.
So I added translate, and it working with ribbon menu!
(I will try to reflect this translation in the translate of collaboration office.)

But sidebar and popup is not working with translate, So I asked that.

Thank you!

Thank you for reply!

Isn’t ALLOWED_LANGUAGES an option that works in Dictionary? In the collaboration code I built,
If set &lang=ko, the translation works in the main menus, but the problem is that it does not work in the sidepanel or popup.
Not only ko but also in the case of de included in ALLOWED_LANGUAGES (de_DE is included!), translation is applied to the main menu, but translation is not applied to the sidepanel, etc.

Where can I find the CollaboraOffice language-package for Korean you mentioned?

Thank you!

I decided to apply the translations directly in the JSDialogBuilder.js file, and it works fine.
Thank you to everyone who commented!

1 Like