Coolwsd failed with let's encrypt?

I have this error when I start coolwsd
Failed to initialize COOLWSD: Access to file denied: /etc/letsencrypt/live/mydomain/fullchain.pem

I use packages Debian : Setting up and configuring native CODE packages on Linux - Collabora Office and Collabora Online

I add my certificates in /etc/coolwsd/coolwsd.xml :

<cert_file_path desc=“Path to the cert file” relative=“false”>/etc/letsencrypt/live/mydomain/cert.pem</cert_file_path>
<key_file_path desc=“Path to the key file” relative=“false”>/etc/letsencrypt/live/mydomain/privkey.pem</key_file_path>
<ca_file_path desc=“Path to the ca file” relative=“false”>/etc/letsencrypt/live/mydomain/fullchain.pem</ca_file_path>

Coolwsd failed :

× coolwsd.service - Collabora Online WebSocket Daemon
Loaded: loaded (/lib/systemd/system/coolwsd.service; enabled; preset: enabled)
Active: failed (Result: signal) since Thu 2024-03-28 00:56:19 CET; 16min ago
Duration: 1.122s
Process: 969252 ExecStart=/usr/bin/coolwsd --version --o:sys_template_path=/opt/cool/systemplate --o:child_root_path=/opt/cool/child-roots --o:file_server_root_path=/usr/share/coolwsd >
Main PID: 969252 (code=killed, signal=ABRT)
CPU: 1.121s

mars 28 00:56:20 coolwsd[969252]: /lib/x86_64-linux-gnu/[0x7f20bee5b050]
mars 28 00:56:20 coolwsd[969252]: /lib/x86_64-linux-gnu/[0x7f20beea9e2c]
mars 28 00:56:20 coolwsd[969252]: /lib/x86_64-linux-gnu/[0x7f20bee5afb2]
mars 28 00:56:20 coolwsd[969252]: /lib/x86_64-linux-gnu/[0x7f20bee45472]
mars 28 00:56:20 coolwsd[969252]: /usr/bin/coolwsd(+0x58b915)[0x55f91378b915]
mars 28 00:56:20 coolwsd[969252]: /lib/x86_64-linux-gnu/[0x7f20bee5b050]
mars 28 00:56:20 coolwsd[969252]: [0x55f915a9ab00]
mars 28 00:56:19 systemd[1]: coolwsd.service: Start request repeated too quickly.
mars 28 00:56:19 systemd[1]: coolwsd.service: Failed with result ‘signal’.
mars 28 00:56:19 systemd[1]: Failed to start coolwsd.service - Collabora Online WebSocket Daemon.

Coolwsd start well if I do :

coolconfig set ssl.enable false
coolconfig set ssl.termination true

How to enable SSL with my let’s encrypt certificates ?



Hey @FredMa01, welcome to the forum and thanks for the question. :slight_smile:

Hmmm, back in 2021, @bearon gave an answer to a similar problem:

It could be Debian has the permissions locked as the “root” user, so you might have to try a few extra things.

Also, what version of Debian are you using?

Thanks for your answer. I will look at this solution.
I am on Debian 12.


Many solutions are proposed but difficult to find the best ;).
There is no official solution from Collabora to use let’s encrypt certificates in Debian 12 ?

The most common problem is **forgetting the SSL setup**. The path to SSL certificate, CA certificate and private key must be valid in /etc/coolwsd/coolwsd.xml. They can be set under ssl as cert_file_path, ca_file_path and key_file_path respectively.

Exit code 70 from coolwsd means internal software error, and this is most likely an issue with accessing certificates. Verify that certificates are set properly in the configuration file, and the files themselves are available with the correct access rights, i.e. readable by the cool user.

I try to change group of “coolwsd.xml” from cool to root but iI’s still failed

-rw-r–r-- 1 root root 29700 8 mars 16:10 coolkitconfig.xcu
-rw-r----- 1 cool cool 30723 28 mars 00:56 coolwsd.xml
-rw------- 1 cool root 1675 27 mars 23:44 proof_key
-rw-r–r-- 1 root root 426 27 mars 23:44

No need for heavy installation of Collabora, everything is integrated by installing these 2 applications: