How to Hide Revision History on Calc?

So, on a recent upgrade of Collabora (using nextcloud), I noticed that whenever I edit a cell it changes the border to red… This is VERY annoying, I cannot find any option to turn this off?

1 Like

Thanks @shaung for reporting it! Could you check if you have the tracking changes on?

What is tracking changes?

This is kind of what I’m asking, i’ve search all of the docs for “revision”, or “history” etc and cannot find anything.

In the recent update the whole menu/toolbar has changed (for the better, it’s great to be honest!), but a lot of buttons have disappeared I think.

Ctrl + Shift + C off
Ctrl + Shift + V on

2 Likes

So very much appreciated, I don’t know why this isn’t documented?

I’d obviously hit it as used to copying from terminal with this combination.

THANKS!

@alex8belov I now have that issue with Docs too, but the same commands doesn’t work there? This is stupid!

In documents, you can open the hamburger menu in the top left corner, choose Track Changes, and disable Record and/or Show.

The keyboard shortcut for this working in Calc is unintended, generally the shortcuts are forwarded to the LibreOffice/Collabora Office-based backend, and that’s the shortcut for enabling/disabling this functionality in those applications.

Ok I see this menu item, that’s where it should be. So why isn’t there one for calc?

I’m not sure what you mean by this:

generally the shortcuts are forwarded to the LibreOffice/Collabora Office-based backend, and that’s the shortcut for enabling/disabling this functionality in those applications.

You are right @shaung

1 Like

We use Calc exclusively and five of us edit a file.
We don’t know how it happened, but the change tracking was suddenly active for us as well. There was definitely no update on the server and the Collabora software.
The mentioned key combinations, Ctrl + Shift + C and/or Ctrl + Shift + V, do nothing in the online version.

The only solution I could think of was to edit the content.xml directly in the Calc file. My procedure was as follows:

Save the “Example.ods” file from the cloud to the local computer system.
Rename the file to “Example.zip”.
Open the file e.g. with 7zip (but do not unzip!).
Open the file “content.xml” for editing.
Search and remove “<table:tracked-changes>” and “</table:tracked-changes>”.
Save the “content.xml” file. 7zip will automatically update the zip file.
Rename the zip file again to “Example.ods” and upload it to the cloud server.

That’s it. Now the tracking is disabled.
Note: I am not an admin and do not have access to the server.

We are using a quite old Collabora version. Maybe the problem is already fixed in newer versions. The described problem was the first big one we ever had to deal with in the version. We had also tested a newer version a long time ago. But it had too many bugs. We don’t have time for such experiments with new versions, as long as the previous version does its job as usual :slight_smile:

Collabora Online Developer Edition 4.0.8
Collabora 6.0-29 - online version used with nextcloud

Hi @TimTom, progress with Collabora Online is phenomenal, 4.0.8 is so old! The 22.05 version is arriving, but I think 21.11 would be best for you.

Here are the release notes for the non-development version, almost the same note as for CODE, but more stable which usually matters for business: Collabora Online 21.11 Release Notes - Collabora Office and Collabora Online

Development Edition: CODE 21.11 Release Notes - Collabora Office and Collabora Online

6.4 is still supported, not sure for how long, I would say definitely go to 21.11: Collabora Online 6.4 Release Notes - Collabora Office and Collabora Online