HowTo Switch – Collabora Online Classic Tool Bar or NotebookBar

First published on:

The recent release of Collabora Online Developer Edition 6.4 yielded us some nice response on the brand new shiny NotebookBar!

Setting in the configuration

Of course, there is the choice which one to use. Currently that is in the configuration file, the loolwsd.xml, in the setting


Choosing at the start

There is also the option to chose at the start of Collabora Online. This is how you switch:

--o:user_interface.mode=classic or --o:user_interface.mode=notebookbar

For example to start the docker without ssl and with classic interface:

docker run -t -d -p 9980:9980 -e "extra_params=--o:ssl.enable=false --o:user_interface.mode=classic" collabora/code

More to come…

We expect a choice in the user interface, accessible for each individual user, will be added soon. Do get a demo, or more info on Collabora’s options for professional support and theming!

More info – or a free Collabora Online demo

Collabora Online development

All about developing Collabora Online and getting involved, can be found on the Collabora Online Community Page.

Thanks for your reply,

I tried to apply these instructions in Univention Corporate Server Version 4.4-6, but it did not work.

I’m using Nextcloud 19.0.4 + Collabora Online Development Edition (CODE) 6.4.0 Appliance

Can you pls describe what/how you tried? And if there was any specific response, or where you got stuck :slight_smile:

I think the previous attempt was wrong, I need to edit loolwsd.xml file.

When trying to edit the configuration file, I didn’t find it.

Searching operation done by excuting this command line “locate loolwsd.xml”.

After that I checked Nextcloud Apps, I find that Collabora Online - Built-in CODE Server is not installed, just Collabora Online App is installed.

I think this is the reason for did not find the lolwsd.xml file, when trying to install this error message appeared “Operation timed out after 120000 milliseconds with 5866051 out of 345741448 bytes received”

With the Built-in CODE server, the timeout when installing can happen, because Nextcloud has a fairly strict time limit on downloading apps. In that case I’d suggest downloading the .tar.gz archive from the app page, unpacking it into your <Nextcloud dir>/apps directory, and changing the owner to www-data with the following command: chown -R www-data:www-data <Nextcloud dir>/apps/richdocumentscode

Nevertheless, the Built-in CODE server isn’t configurable, thus I would suggest using either the packages or running a docker container.


Hi there.

Also: does not work for me.
I use docker collabora/code with the regular nextcloud connector - not the build-in server.

I tried both using a complete loolwsd.xml file inside the docker container and an environment variable. in both cases I can verify a seemingly well set option:

root@03beda33c139:/# grep notebook /etc/loolwsd/loolwsd.xml -B 1 -A 1
      <mode type="string" desc="Controls the user interface style (classic|notebookbar)" default="classic">classic</mode>

still it does not show the classic toolbar.

Well, I re-read your initial post.
So the environment variable --o:user_interface.mode=classic works while user_interface=classic does not.
(Seems to me that both result in the same loolxsd.xml entry, but whatever.

Now my question would rather be: do the other environment options still work or is there an update how to set environment variables when starting docker containers?
So far, I use: dictionaries=de_DE… , domain=…, username=… and password=…