Loolwsd command line option for log file

I’m trying to set the log file on the loolwsd command line. I’ve tried the following:

–o:logging.file.path=/var/log/loolwsd-dev.log
–o:logging.file[path]=/var/log/loolwsd-dev.log
–o:logging.file[@path]=/var/log/loolwsd-dev.log

None of the above seems to work. Works fine if I set the value in loolwsd.xml.

What is the correct syntax to set the path property of logging.file on the command line?

Have you tried adding double quotes around the path?

Thanks bearon, but I think the problem is with the xpath expected by the --o option. The correct xpath (as tested with Online XPath Tester and Evaluator) for the property is:

/config/logging/file/property[@name=‘path’]

This xpath does return the correct xml element, but I’m having trouble converting this xpath into the correct --o syntax. None of these seem to work:

–o:logging.file.property[@name=‘path’]="/var/log/loolwsd-70.log"
–o:config.logging.file.property[@name=‘path’]="/var/log/loolwsd-70.log"
–o:/config/logging/file/property[@name=‘path’]="/var/log/loolwsd-70.log"

It’s strange, I have no idea why the first variant doesn’t work.