PDF save/download broken [resolved]

New install of 6.4 with NextCloud 21.0. Writer works and is able to save ODT files. PDF edit doesn’t work at all. The Save As option is greyed out and if I make comments on the PDF, they appear, however, when I try to Save Comments, I get an error message “Document cannot be saved. Check your permissions or contact the storage server administrator.” Since ODT files in the same storage work without issue, the PDF functions are suspect to me. I’ve tried running both packages and docker container on CentOS 8.3 with and without Apache 2.4.37 as a proxy. Here are the error messages I see:

wsd-00006-00044 2021-03-16 21:56:47.061256 [ docbroker_001 ] ERR Cannot store docKey [/index.php/apps/richdocuments/wopi/files/631_oc961j38hjyu] as .uno:Save has failed in LOK.| wsd/DocumentBroker.cpp:1028
wsd-00006-00044 2021-03-16 21:56:47.061291 [ docbroker_001 ] ERR error: cmd=storage kind=savefailed| ./common/Session.hpp:136

Not sure what happened here, but I just tried editing the same document on the same unchanged server. It didn’t work before, but now does. There are problems with the PDF edits, but that’s a separate problem that I will open a GitHub issue for.