Weird / arbitrarily behavior of Collabora Online

So I’ve been experiencing some very strange behavior alongside Collabora Online. Since migrating to a new Collabora Online Server (version 21.11.3), nothing works reliably anymore. All the abnormalities described in the following follow no pattern, are totally unpredictable and therefore cannot be reproduced.

  • The save button sometimes work and sometimes it does not. Meaning the changes sometimes get saved on the file server as it should be and sometimes no http request to the wopi host is made. I tried to manually save with the help of the PostMessageAPI. When adding an event listener to the iframe window the Collabora Online editor is embedded in, I notice that it rarely gets trigered upon user actions such as “saving the document.” Feels very buggy to me.

  • Often the document is loaded and rendered instantly without any problems. When trying to load the same document some time later, it sometimes happens that the content of the iframe schows me some weird error messages. I attached them as hyperlinks. The first error message says that it is cleaning up the document from the last session. Whatever that means, it can last for hours. The second error message says it cannot establish a connection to the document (although it worked minutes before).

Could this be a configuration error on a server Collabora Online is running/depending on?

What would be most useful is seeing logs of Collabora Online, preferably of trace level. However, trace level logs can grow quickly, and also impact performance, so that doesn’t seem to be feasible in your case. Maybe for starters normal warning level logs would be interesting as well.

In addition, if you could describe your setup, ie. whether you use packages or container, reverse proxy, what your WOPI host is etc., that’d be great.