Disable spell correction permanently


we have an .xlsx spreadsheet on our nextcloud to be shown permanently on an always-on display as a daily overview. For this the sheet is shared with a user which has only read-rights. He cannot change the spell correction option, so by default all words (we use only abreviations) are underlined with red. Sometimes we have to restart the computer/browser meaning, even if I disable spell correction by login in with the admin-user (write-rights) and disable the spell correction, it will return once we restart the computer/browser.

Is there a way to disable spell correction permanently? I tried to deactivate it and saved the file, this is not enough.

Thank you!

Hey @SLKRadiologie. Welcome to the forum and thanks for the question. :slight_smile:

Sounds like read-only is causing some gremlins. :slight_smile:

Do you happen to have a Github account?

If you do, can you submit an issue to the:

After you submit the issue, the QA team can verify and a dev can look into it.

I suspect it would just require an enhancement to let a user in “read-only mode” turn on/off spellchecking.

You’re welcome. :slight_smile:

Thank you for your reply.

Here’s the issue:

Spell correction annoyingly turned on for read-only users · Issue #7935 · CollaboraOnline/online (github.com)

1 Like

Absolutely fantastic @SLKRadiologie .

I brought it up today in the COOL Weekly Meeting #150 too, so QA/devs are now aware of it.

There were a few other “read-only” bugs a developer was recently squishing, so perhaps they might tackle this one too. :slight_smile:

Spellchecking squigglies should definitely be toggleable (or Ignorable), even if in read-only.

That Github issue will then have the latest info/fixes/updates as they occur. Thanks again for the report! :slight_smile: