Real-time cursor tracking not working

Hello, I am running Nextcloud 28.0.2 and Collabora but real-time cursor tracking is not working on spreadsheet files. I tried with an existing one first, then I tried to create a new spreadsheet and share it with another user but enabling the function (by the “connected users” circles) doesn’t have any effect.

I tried to check from the console of the browser developer tools but no message is shown when an user moves on the file or when the function is enabled/disabled.

What can I do in order to debug the reason of it? Is everything working fine for you?

Hey @pixel8383,

Thanks for this bug report.

Do you have a Github account?

Could you then:

Also, it would be helpful if you could:

  1. Create a screen recording showing off the problem.

Hmmm… This one sounds a little bit trickier too.

If you wanted to debug this one even further…

This is how you get to a “super secret” debug menu that devs use to potentially figure out what’s going on:

  1. Go to Help > About.
  2. When the “About” menu pops up, you can:
    • Triple-Click your mouse on the menu itself.

This will open up the debug menu.

Then, you can follow the “Developer Tools” instructions here:

After you press F12 in your browser—with that debug menu open + checkboxes like Protocol Logging + Tile Dumping ON—you should get more stuff showing in the browser’s logs as you click around and test things.

Well, I believe you could be the first to report such an issue like this. So thanks. :slight_smile: